[yocto] version problems about SDK

Tian, Kevin kevin.tian at intel.com
Mon Dec 13 04:22:06 PST 2010


>From: Joshua Lock
>Sent: Monday, December 13, 2010 8:01 PM
>
>On Sun, 2010-12-12 at 23:53 -0800, Zhang, Jessica wrote:
>> Tian, Kevin wrote:
>> >> From: Ke, Liping
>> >> Sent: Monday, December 13, 2010 2:53 PM
>> >>
>> >> Hi, Jessica & Josh
>> >>
>> >> When we are trying to run installer script on lianhao's x86_64
>> >> machine, we found if the images are build in two days, according to
>> >> current version naming convention, some of the packages will be
>> >> installed to /opt/poky/0.9+snapshot-20101210, some will be to
>> >> /opt/poky/0.9+snapshot-20101210.
>> >> It will cause problem since we need to know the exact version number
>> >> before installing and searching some files (environment script file,
>> >> etc). And the same releases of packages belong to different version
>> >> (just the build date is not in the same day) seems very strange and
>> >> hard to handle for us?
>> >>
>> >
>> > I think Josh has laid down the base for multiple version SDK support.
>> > The only problem is:
>> >
>> > SDKPATH = "/opt/${DISTRO}/${DISTRO_VERSION}"
>> >
>> > which obviously is not what we want. We need a similar variable like
>> > SDK_VERSION, which is incremented only when SDK team thinks there's a
>> > need for a new version release or
>> > else it keeps same in the life cycle of current version.
>
>I disagree, I think it's definitely useful to know which distribution
>version your SDK is built against. In fact as the SDK components are
>generated from the distro metadata introducing an extra variable seems a
>little superfluous and just increases the number of things which need to
>be changed for a release.

Yes, SDK is generated from the distro metadata, which however doesn't prevent SDK
as a standalone component to have its own version variable. We can have:

SDK_VERSION = ${DISTRO_VERSION}

or, 

SDK_VERSION = ${DISTRO_VERSION}${SDK_REVISION}

or, 

SDK_VERSION = ...

I'm just a little bit worried to deduce SDK version from another variable (SDKPATH)
implicitly.

I agree that to have distribution version included will be informative, e.g in Android:
	"SDK platform Andriod 2.3, API 9, revision 1"

>
>Also note the DATE element is only included in the DISTRO_VERSION for
>development snapshots.
>

Good to know this info.

Thanks
Kevin



More information about the yocto mailing list