[yocto] version problems about SDK

Zhang, Jessica jessica.zhang at intel.com
Mon Dec 13 14:33:33 PST 2010


Joshua Lock wrote:
> On Sun, 2010-12-12 at 23:53 -0800, Zhang, Jessica wrote:
>> Tian, Kevin wrote:
>>>> From: Ke, Liping
>>>> Sent: Monday, December 13, 2010 2:53 PM
>>>> 
>>>> Hi, Jessica & Josh
>>>> 
>>>> When we are trying to run installer script on lianhao's x86_64
>>>> machine, we found if the images are build in two days, according to
>>>> current version naming convention, some of the packages will be
>>>> installed to /opt/poky/0.9+snapshot-20101210, some will be to
>>>> /opt/poky/0.9+snapshot-20101210.
>>>> It will cause problem since we need to know the exact version
>>>> number before installing and searching some files (environment
>>>> script file, etc). And the same releases of packages belong to
>>>> different version (just the build date is not in the same day)
>>>> seems very strange and hard to handle for us? 
>>>> 
>>> 
>>> I think Josh has laid down the base for multiple version SDK
>>> support. The only problem is: 
>>> 
>>> SDKPATH = "/opt/${DISTRO}/${DISTRO_VERSION}"
>>> 
>>> which obviously is not what we want. We need a similar variable like
>>> SDK_VERSION, which is incremented only when SDK team thinks there's
>>> a need for a new version release or
>>> else it keeps same in the life cycle of current version.
> 
> I disagree, I think it's definitely useful to know which distribution
> version your SDK is built against. In fact as the SDK components are
> generated from the distro metadata introducing an extra variable
> seems a little superfluous and just increases the number of things
> which need to be changed for a release.
> 
> Also note the DATE element is only included in the DISTRO_VERSION for
> development snapshots.
> 

Since the DATE element is only included in the DISTRO_VERSION for
development, then I'd suggest that our SDK_VERSION logic to be as:
If DISTRO_VERSION contains snapshot
SDK_VERSION = 0.9+snapshot (stripe off the date part)
Else
SDK_VERSION = DISTRO_VERSION (which means the DISTRO is a stablized and
meaningful version, e.g. M3_RC1, etc, or 1.0 relrease, etc.)

SDKPATH = "/opt/${DISTRO}/${SDK_VERSION}"

This way we can easily link the SDK_VERSION to DISTRO_VERSION and avoid the
unnecessary version issue during the development cycle...
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 8455 bytes
Desc: not available
URL: <http://lists.yoctoproject.org/pipermail/yocto/attachments/20101213/38480fda/attachment.bin>


More information about the yocto mailing list