[meta-freescale] trying to boot a bitbaked image in various ways

Otavio Salvador otavio at ossystems.com.br
Mon May 20 11:32:57 PDT 2013

On Fri, May 17, 2013 at 12:45 PM, Thanassis Silis <djnass_18 at hotmail.com>wrote:

> Hi there, I am trying to boot the image I created in several ways:
> 1) extracted the tar.bz2 image (with tar xjvf) and did an nfs boot
> directly from the sabrelite board ! This succeeded.


> 2) copied the .sdcard image to an microSD card and tried to boot locally
> from the microSD. This fails as the uboot version on the board is the one
> that sabrelite shipped with , (2009.08 i think). How do I go about updating
> the uboot (.imx file) that has generated from bitbake process?

You should 'dd' the .sdcard file to your microSD card.

> 3) I started reading on yocto project and tried runqemu but it fails. Here
> is what I did:
>         cd <yocto root>/sources/poky/
>         . ./oe-init-build-env
>         cd build #done automatically at exit from above script
>         runqemu ../../../build/tmp/deply/images/uImage-blabla.bin
> ../../../build/tmp/deply/images/fsl-image-test-blabla.ext3 ext3
> the qemu start running,

The image built for SabreLITE won't be compatible with QEMU so it is
expected to fail.


Otavio Salvador                             O.S. Systems
http://www.ossystems.com.br        http://projetos.ossystems.com.br
Mobile: +55 (53) 9981-7854            Mobile: +1 (347) 903-9750
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/meta-freescale/attachments/20130520/a4c01138/attachment.html>

More information about the meta-freescale mailing list