[meta-freescale] trying to boot a bitbaked image in various ways

Thanassis Silis djnass_18 at hotmail.com
Fri May 17 08:45:12 PDT 2013

Hi there, I am trying to boot the image I created in several ways:
1) extracted the tar.bz2 image (with tar xjvf) and did an nfs boot directly from the sabrelite board ! This succeeded.
 copied the .sdcard image to an microSD card and tried to boot locally 
from the microSD. This fails as the uboot version on the board is the 
one that sabrelite shipped with , (2009.08 i think). How do I go about 
updating the uboot (.imx file) that has generated from bitbake process?

3) I started reading on yocto project and tried runqemu but it fails. Here is what I did:
        cd <yocto root>/sources/poky/
        . ./oe-init-build-env
        cd build #done automatically at exit from above script
 runqemu ../../../build/tmp/deply/images/uImage-blabla.bin 
../../../build/tmp/deply/images/fsl-image-test-blabla.ext3 ext3
 the qemu start running, 

nass at starland ~/yocto/sources/poky/build $ runqemu 
images/fsl-image-test-imx6qsabrelite-20130515000446.rootfs.ext3 ext3

Set MACHINE to [uImage-imx6qsabrelite.bin] based on kernel [images/uImage-imx6qsabrelite.bin]

Continuing with the following parameters:

KERNEL: [images/uImage-imx6qsabrelite.bin]

ROOTFS: [images/fsl-image-test-imx6qsabrelite-20130515000446.rootfs.ext3]

FSTYPE: [ext3]

but halts after a while:

There was an error running bitbake to determine TMPDIR

Here is the output from 'bitbake -e':

<huuuuge dump of exported variables and python code following>


Am I using the command wrongly?
  Thank you for your help on both matters.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/meta-freescale/attachments/20130517/f37894e8/attachment.html>

More information about the meta-freescale mailing list