[yocto] how to copy a tar file to Root file system

Swapna.Gurumani at microchip.com Swapna.Gurumani at microchip.com
Wed Nov 2 13:17:11 PDT 2016

> Also if I look into the
> /home/swapna/workspace/work/yocto/poky/build-atmel/tmp/work/cortexa5hf
> -neon-
> poky-linux-gnueabi/crank/1.0-r2 It is empty.

There's something strange going on here, because the path you have just given is ${WORKDIR} - and that shouldn't be able to be empty at this point. If nothing else there should be a "temp" directory under it containing logs if
*any* tasks have run. Surely you have skipped out some steps between when it was working and now? I notice the tarball name changed - did you regenerate it or just rename it?

Answer>> I renamed it. For some reason it was. But now its populated with lot of stuff including the crank folder, temp, image etc..

In any case, when debugging situations like this it helps to make a fresh start - run "bitbake -c clean crank" (you don't need -c cleansstate because being stuck at do_install you haven't got to any real sstate tasks yet). Then methodically run through each task - when do_unpack ran what got unpacked into ${WORKDIR}? If that's as expected, what got put into ${D} (which is the "image" subdirectory under ${WORKDIR})? Does what's in ${D} match up with the layout you expect to be on the target? At any time you can use "bitbake -e crank | less" to inspect the value of variables. You can also see exactly what commands got run within the task by looking at the run.do_* files under "temp" in the workdir.
ANSWER >> All this looks good. The run.do* files don't show much. Although, why am I seeing stuff like:
NOTE: arm-poky-linux-gnueabi-objdump -p /home/swapna/workspace/work/yocto/poky/build-atmel/tmp/work/cortexa5hf-neon-poky-linux-gnueabi/crank/1.0-r0/packages-split/crank/opt/crank/linux-sama5d-armle-fbdev-obj/lib/luagretest.so

In log.do_package_qa?

* Based on what you've said earlier, your S value cannot be correct - it may not matter, but it might as well be fixed anyway. If the tarball unpacks a "crank" subdirectory then it should be set to "${WORKDIR}/crank".

ANSWER >> I get the same error no matter what the S is set to:
non -staticdev package contains static .a library: crank path 'work/cortexa5hf-neon-poky-linux-gnueabi/crank/1.0-r0/packages-split/crank/opt/crank/linux-sama5d-armle-fbdev-obj/lib/libssgf.a' [staticdev]

WHY am I getting this error?

* Setting DEPENDS isn't really doing you any good - DEPENDS is for build-time dependencies. You're only unpacking a tarball, you don't need any build-time dependencies to speak of. If you have runtime dependencies then set them in RDEPENDS_${PN} since that's where runtime dependencies need to be set.

ANSWER>> without that line, I get the following error:

WARNING: crank-1.0-r0 do_package_qa: QA Issue: crank rdepends on tslib, but it isn't a build dependency, missing tslib in DEPENDS or PACKAGECONFIG? [build-deps]
WARNING: crank-1.0-r0 do_package_qa: QA Issue: crank rdepends on libasound, but it isn't a build dependency, missing alsa-lib in DEPENDS or PACKAGECONFIG? [build-deps]

* As another responder pointed out, the inherit of pkgconfig isn't needed - you don't need pkg-config for anything being done here.
Again, same error with or without this. Or even if I use " inherit bin_package"



Paul Eggleton
Intel Open Source Technology Centre

More information about the yocto mailing list