[meta-freescale] Error compiling barebox on fido

György Kövesdi kgy at teledigit.eu
Mon Jun 22 01:25:11 PDT 2015


I found that really the gcc causes the problem.
I created this test file (x.c):

#include <stdio.h>
int main() {}

I tried to compile it this way:

arm-poky-linux-gnueabi-gcc x.c

On fido it fails, while on daisy, it succeeds.
I see that gcc 4.9 on fido does not have standard includes by default, 
while gcc 4.8 on daisy does. However, it is set in CFLAGS, so all 
compilation succeeded this way.
I will resolve barebox build by changing its make rules, but i don't 
know if this is a problem with gcc 4.9 or not. Which behaviour is standard?

Gyorgy Kovesdi

On 2015-06-21 18:32, Gyorgy Kovesdi wrote:
> Hi,
> I tried to compile barebox_2015.06 on the current fido, and got the following error:
>    arm-poky-linux-gnueabi-gcc -Wp,-MD,scripts/.bareboxenv-target.d -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -Werror-implicit-function-declaration -fno-strict-aliasing -fno-common -Os -pipe  -fno-stack-protector -Wno-unused-but-set-variable -Wno-trampolines -Wdeclaration-after-statement -Wno-pointer-sign -o  scripts/bareboxenv-target scripts/bareboxenv.c
> scripts/bareboxenv.c:20:19: fatal error: stdio.h: No such file or directory
>    #include <stdio.h>
>                     ^
> compilation terminated.
> Exactly the same command is executed when building on odler revisions (e.g. on current daisy), without problem.
> The difference I see that fido uses gcc 4.9 and daisy uses 4.8, but I think this is not the cause.
> What can be the problem?
> Thanks in advance
> György Kövesdi

More information about the meta-freescale mailing list