[meta-freescale] meta-qt5 and WebKit2 examples?

BERTIN, NICOLAS (NICOLAS) Nicolas.Bertin at alcatel-lucent.com
Fri Mar 7 06:29:51 PST 2014

>>When I build Qt outside of yocto, the WebKit2 examples are running
>>but the web content is not displayed (even if I'm pretty sure that the
>>QtWebProcess is working behind the scene...)
>I have exact same problem and already tried many things with various
gles/egl options around Qt & WebKit.
>There is no known solution right now, it seems like no one wants to dig
into WebKit sources, and
>unfortunately, >problem lies somewhere there in EGL platform support.
Moreover - in X11 you can see mouse
>changing cursor on input >fields and links, so WebKit actually works, just
the rendering to EGL is broken.
>If you will have any success with this - poke me and I will test on my
Debian i.MX6Q system.
>Best Regards,
>Dmitriy Beykun

Oh ! Thank you, I feel less alone, now !

The only real patch that I have tried is from this blog:

This is also the only successful integration of Qt5+eglfs/WebKit2 that I've
found. Unfortunately, not on
the "right" platform...

To be continued.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 4416 bytes
Desc: not available
URL: <http://lists.yoctoproject.org/pipermail/meta-freescale/attachments/20140307/d6e39cca/attachment.bin>

More information about the meta-freescale mailing list