<html>
  <head>

    <meta http-equiv="content-type" content="text/html; charset=utf-8">
  </head>
  <body text="#000000" bgcolor="#FFFFFF">
    <p><font face="Monaco">Hi,</font></p>
    <p><font face="Monaco"><br>
      </font></p>
    <p><font face="Monaco">I've added zeromq to a build by adding the
        meta-iot-cloud layer. This adds zeromq to the target rootfs, but
        I can't get this added to the host rootfs when I create an sdk (
        using bitbake -c populate_sdk core-image-minimalĀ  ).<br>
      </font></p>
    <p><font face="Monaco"><br>
      </font></p>
    <p><font face="Monaco">I've read about adding something like <br>
      </font></p>
    <p><b style="color: rgb(100, 100, 102); font-family: "Source
        Sans Pro", sans-serif; font-size: 16px; font-style: normal;
        font-variant-ligatures: normal; font-variant-caps: normal;
        letter-spacing: normal; orphans: 2; text-align: left;
        text-indent: 0px; text-transform: none; white-space: normal;
        widows: 2; word-spacing: 0px; -webkit-text-stroke-width: 0px;
        background-color: rgb(255, 255, 255); text-decoration-style:
        initial; text-decoration-color: initial;">TOOLCHAIN_HOST_TASK_append
        = " zeromq"</b></p>
    <p><font face="Monaco">to my conf/local.conf, however, I only see
        error messages saying <br>
      </font></p>
    <p><font face="Monaco"><br>
      </font></p>
    <font face="Monaco">NOTE: Executing SetScene Tasks<br>
      NOTE: Executing RunQueue Tasks<br>
      ERROR: core-image-minimal-dev-1.0-r0 do_populate_sdk: zeromq not
      found in the feeds (x86_64-nativesdk noarch any all) in
      /media/build/morty/build/tmp/deploy/rpm.<br>
      ERROR: core-image-minimal-dev-1.0-r0 do_populate_sdk: This is
      often caused by an empty package declared in a recipe's PACKAGES
      variable. (Empty packages are not constructed unless
      ALLOW_EMPTY_<pkg> = '1' is used.)<br>
      ERROR: core-image-minimal-dev-1.0-r0 do_populate_sdk: Function
      failed: do_populate_sdk<br>
      ERROR: Logfile of failure stored in:
/media/build/morty/build/tmp/work/nitrogen6x-fslc-linux-gnueabi/core-image-minimal-dev/1.0-r0/temp/log.do_populate_sdk.20519<br>
      ERROR: Task
(/media/build/morty/sources/poky/meta/recipes-core/images/core-image-minimal-dev.bb:do_populate_sdk)
      failed with exit code '1'<br>
      <br>
      <br>
      What is the approved way to add a library that was compiled for
      the target to the hostĀ  ? <br>
      <br>
      <br>
      <br>
      <br>
      <br>
    </font>
  </body>
</html>