[yocto] ** Potentially Unsafe Email ** Re: Screenshot tool

Evan O'Loughlin evan.oloughlin at vitalograph.ie
Wed Apr 24 09:15:36 PDT 2019

Hi all,

Just an update in case anyone else has run into the same issue.

Typically our app is run as follows:
./app -platform eglfs

But when I use the following I can capture the data displayed on-screen:
./app -platform linuxfb:fb=/dev/fb0

It may not be exactly what I wanted but it gives me a relatively straight-forward way to capture screenshots for our user documentation.

Credit goes to this comment  https://stackoverflow.com/questions/50236156/making-a-qt-gui-application-run-on-a-framebuffer-in-linux#comment87592068_50236352 


-----Original Message-----
From: yocto-bounces at yoctoproject.org [mailto:yocto-bounces at yoctoproject.org] On Behalf Of Evan O'Loughlin
Sent: 17 April 2019 17:09
To: 'yoctoproject.org at herrie.org' <yoctoproject.org at herrie.org>
Cc: yocto at yoctoproject.org
Subject: ** Potentially Unsafe Email ** Re: [yocto] Screenshot tool

Hi Herman,

Thanks for providing links to the screenshooter source.

Based on your code I've tried implementing a similar method within our application but I still get a blank (black) image.

It's possible that under the hood the 'grabWindow' method is just saving the framebuffer.


-----Original Message-----
From: Herman van Hazendonk [mailto:me at herrie.org]
Sent: 16 April 2019 10:19
To: Evan O'Loughlin <evan.oloughlin at vitalograph.ie>
Cc: yocto at yoctoproject.org
Subject: Re: [yocto] Screenshot tool

Hi Evan,

We don't currently have a 4.9 kernel running for our project since we're working mainly with mobile devices which are stuck on 3.4 and 3.18 kernels for now, however we do have small screenshot utility which we have as a plugin to our compositor which we have been using since early
Qt5 releases and we're currently on Qt 5.11/5.12.

Might be worth to give a go at your end:


And the header file at:


Hope this helps.

Best regards,

On 2019-04-16 09:15, Evan O'Loughlin wrote:
> Hi,
> I’m currently using yocto to build a custom OS based on Linux 4.9 for 
> our hardware:
> Build Configuration:
> BB_VERSION        = "1.32.0"
> BUILD_SYS         = "x86_64-linux"
> NATIVELSBSTRING   = "Ubuntu-16.04"
> TARGET_SYS        = "arm-linux-gnueabi"
> DISTRO            = "arago"
> DISTRO_VERSION    = "2017.12"
> TUNE_FEATURES     = "arm armv7a vfp thumb neon       
> callconvention-hard"
> TARGET_FPU        = "hard"
> meta-processor-sdk = "HEAD:92db4d8023d88ab59fab2953e7447ec0bd5a6db1"
> meta-ros          = "HEAD:e2566402ab108a19634354a934788109422cf409"
> meta-arago-distro
> meta-arago-extras = "HEAD:5b2a44b0c4d989133bc13d59398fd10375d351bb"
> meta-browser      = "HEAD:26d50665e2f7223c5f4ad7481a8d2431e7cb55fb"
> meta-openamp      = "HEAD:8a214032bfb7e8124bc1485c70c69f7d60abb819"
> meta-qt5          = "HEAD:2c9f0e4eb0e9097f6f872ec1e1d81768a8ab5f1b"
> meta-networking
> meta-ruby
> meta-python
> meta-oe
> meta-gnome
> meta-multimedia   = "HEAD:b40116cf457b88a2db14b86fda9627fb34d56ae6"
> meta-ti           = "HEAD:3dc08477529b31ce887bb22a08201a843ded48f0"
> meta-linaro-toolchain
> meta-optee        = "HEAD:d73e794c7e7ebb1cc5bf495a52a72b26fb118250"
> meta              = "HEAD:39fd8c129e2bff7f2f1649b7f6e036ccc50fd5d8"
> meta-custom  = "########################################"
> meta-printing     = "morty:72811bc3755d1a943fa2a2e79601781b44a77420"
> We run a Qt5 application using EGLFS but can no longer capture 
> screenshots.
> In a previous yocto build based on Linux 3.x we were able to use a 
> screenshot tool which effectively just read /dev/fb0 to a file.
> I believe this was a change to how the underlying drivers interact 
> with the GPU/Screen - I've started reading up on KMS/DRM.
> Does anyone know is there a utility/tool which I could use to capture 
> the Qt5 application as its drawn on screen?
> Regards,
> Evan
yocto mailing list
yocto at yoctoproject.org

More information about the yocto mailing list