[yocto] [EXTERNAL] Re: Openjdk-8 fetcher failure

Pawar, Alok Alok.Pawar3 at harman.com
Tue Jun 20 22:28:39 PDT 2017

HI John, 

Using the 'wget',  I am able to download the file.

Best Regards
Alok Pawar
Sr. Engineer Product Development

-----Original Message-----
From: Maxin B. John [mailto:maxin.john at intel.com] 
Sent: Monday, June 19, 2017 6:37 PM
To: Pawar, Alok <Alok.Pawar3 at harman.com>
Cc: yocto at yoctoproject.org
Subject: [EXTERNAL] Re: [yocto] Openjdk-8 fetcher failure

Hi Alok,

On Mon, Jun 19, 2017 at 06:11:20AM +0000, Pawar, Alok wrote:
>Hi All,
> I am using yocto 2.1.2 krogoth, and I added meta-java in it, but when I tried to bitbake. I faced fetcher failure, following are the Error :
>ERROR: openjdk-8-102b14-r0 do_fetch: Fetcher failure: Fetch command failed with exit code 4, output:
>  Read error (Connection timed out) in headers.
>  Read error (Connection timed out) in headers.
>ERROR: openjdk-8-102b14-r0 do_fetch: Function failed: Fetcher failure for URL: 'http://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/archive/ac29c9c1193a.tar.bz2;name=hotspot;unpack=false'. Unable to fetch URL from any source.
>Please give your inputs.

This could be related to the network configuration in your build machine.

Have you tried to fetch that file manually using wget from your machine ?
# wget http://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/archive/ac29c9c1193a.tar.bz2

Best Regards,

More information about the yocto mailing list