[yocto] Compiling meta-browser ==>chromium ? cleaning ?

Riko Ho antonius.riko at gmail.com
Mon Jun 19 20:32:34 PDT 2017

My memory is 8Gb and swap 8Gb, 8 cores i7, may be a homemade cluster can 
help ?

I compiled firefox and it worked well, but still wondering why chromium 
didn't work.

On 20/06/17 04:01, Khem Raj wrote:
> On Mon, Jun 19, 2017 at 7:21 AM, Jacobo Aragunde Pérez
> <jaragunde at igalia.com> wrote:
>> On 18/06/17 20:10, Gunnar Andersson wrote:
>>> Riko Ho <antonius.riko at gmail.com> wrote:
>>>> Hello Everyone,
>>>> I tried to compile chromium but never succeeded, took me already 12
>>>> hours and stopped on 99%, I used bitbake for doing it,
>>> Not sure what would cause it to just stop and it could have been some
>>> temporary glitch?   Maybe you want to provide some logs of your build if
>>> Martin's reference does not help.
>> Just a heads-up, if it stopped at 99% it probably was in the linking
>> phase (you can check the logs under
>> tmp/work/$arch/chromium-wayland/$version/temp/log.do_compile to be
>> certain). This phase has a very high RAM demand, you could even need to
>> temporarily increase your swap space to go past that point.
> linker takes a whole lot of memory here, if you have < 8G of RAM
> its likely to fail with out of memory errors. Can you check your dmesg
> and see if there were such errors in there
>> Best,
>> --
>> Jacobo Aragunde
>> Software Engineer at Igalia
>> --
>> _______________________________________________
>> yocto mailing list
>> yocto at yoctoproject.org
>> https://lists.yoctoproject.org/listinfo/yocto


Sent by Ubuntu LTS 16.04,
Riko Ho

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/yocto/attachments/20170620/64b87665/attachment.html>

More information about the yocto mailing list