[yocto] Including TUN/TAP kernel drivers for openVPN

Brett R. Nicholas Brett.R.Nicholas.TH at dartmouth.edu
Thu Jun 1 10:40:21 PDT 2017

Hi there,

I'm using Yocto (morty) to build a custom linux image for a Zedboard. I need  the image to run openVPN, which requires access to the TUN/TAP virtual network interface. I successfully incorporated openVPN and all its dependencies into my image using the meta-networking layer, but it appears that the necessary TUN/TAP kernel drivers are not present in the image.

How can I ensure that the TUN/TAP kernel drivers are included in my image?

I have the following two lines in my conf/local.conf file:

IMAGE_INSTALL_append = " kernel-modules"

CORE_IMAGE_EXTRA_INSTALL += "openssl openvpn docker tunctl

I don't know how I could include them in my image. I tried adding kernel-module-tun to my IMAGE_INSTALL_append as mentioned here (https://lists.yoctoproject.org/pipermail/yocto/2014-September/021698.html)<https://lists.yoctoproject.org/pipermail/yocto/2014-September/021698.html>, but it does not appear this is a valid package provided by any of my layers. Maybe I am doing this part incorrectly?

I also tried using bitbake -c menuconfig virtual/kernel to manual include the modules in the image, however after doing this and rerunning bitbake core-image-minimal I still did not see tun.ko appear in either of the two locations below that I would expect them to be installed to:




I should note that I'm using the meta-xilinx and meta-xilinx-tools layers in addition to a few custom layers of my own. None of these should affect this problem, AFAIK.

Any help appreciated, thanks!
- Brett
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/yocto/attachments/20170601/1444e30b/attachment.html>

More information about the yocto mailing list