[yocto] The best way to change target architecture

Zhuoqun Cheng czq at bu.edu
Tue Jun 6 05:42:10 PDT 2017

Hi Yocto Experts,

I'm fairly new to Yocto and I've already tried my best to search for
answers, but not happy with what I found.

So here's the situation I've got:

I'm using yocto to build the intel aero board image, following this link:

Everything worked fine, until I wanted to change the target architecture
from the default 64-bit x86 to 32-bit x86. What I did is three steps:
1. do a clean: bitbake -c clean intel-aero-image
2. change configuration, from "require conf/machine/intel-corei7-64.conf"
to "require conf/machine/intel-core2-32.conf" in the file
3. do a build: bitbake intel-aero-image

Unfortunately, I got loads of errors, like "ERROR:
linux-yocto-4.4.60+gitAUTOINC+2cc78e92f4-r0 do_package_qa: QA Issue:
Architecture did not match (3 to 62) on

Then I tried deleting all the files in the packages-split directory and
rebuilding. It passed building the kernel (even though failed because some
other package's arch mismatch), but those file I deleted never got
generated again! Now I'm a bit worried.

So I guess my question is:
What is the correct procedures to follow to reuse a poky folder (already
built once) for a different target architecture? I'm happy to accept any
links and suggested readings.

Thanks a lot!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/yocto/attachments/20170606/7ad27e8d/attachment.html>

More information about the yocto mailing list