[yocto] Why can't I install eudev-hwdb

Alejandro del Castillo alejandro.delcastillo at ni.com
Fri Jun 2 13:09:46 PDT 2017

On 06/01/2017 09:52 AM, Gary Thomas wrote:
> On 2017-06-01 15:46, Burton, Ross wrote:
>> On 1 June 2017 at 14:38, Gary Thomas <gary at mlbassoc.com
>> <mailto:gary at mlbassoc.com>> wrote:
>>     Thanks for the suggestion.  Sadly, still no go.
>> No idea then.  CCing Alejandro...
> Very interesting - I'm building two different system images for this
> target and I tried to apply the BAD_RECOMMENDS to only one of them.
> The target images (pure result of bitbake) did the right thing, one
> image had eudev-hwdb and the other did not.  The image without eudev-hwdb
> seems to be never able to install it using opkg install/upgrade, but
> only if the package would need to be downloaded from the IPK server.
> I copied the appropriate IPK package to that image manually and opkg
> happily installed it from the direct file.


Which version of opkg are you using? do you have the libsolv backend
enabled? running opkg --version should tell you the opkg version and the
libsolv version, if the backend is enabled.

Also, could you send a verbose log of the installation? opkg install -V4
<pkg_name>. While you are at it, it would be helpful to attach your
/var/lib/opkg/status file too.



More information about the yocto mailing list