[yocto] devshell, KDE konsole & python3 TypeError

Michel D'HOOGE michel.dhooge at free.fr
Fri Nov 18 12:49:12 PST 2016


I'm on Morty and I hit the following bugs when trying to launch a devshell… I did a quick search and don't think they are solved.

In poky/meta/lib/oe/terminal.py, the option "--nofork" doesn't exist in my konsole v16.08.
I replaced it by option "--new-tab", which solved the problem.

And with my python 3.5.2, the oe.terminal.ExecutionError triggers another exception when printing the output:

File: '/mnt/Yocto/sources/poky/bitbake/lib/bb/process.py', lineno: 46, function: __str__
     0042:        message = ""
     0043:        if self.stderr:
     0044:            message += self.stderr
     0045:        if self.stdout:
 *** 0046:            message += self.stdout
     0047:        if message:
     0048:            message = ":\n" + message
     0049:        return (CmdError.__str__(self) +
     0050:                " with exit code %s" % self.exitcode + message)
Exception: TypeError: Can't convert 'bytes' object to str implicitly

If this can help others…


More information about the yocto mailing list