[yocto] Tcl SIGCHLD lost process error

Mircea Gliga mircea.gliga at vitheia.com
Tue Nov 1 23:32:46 PDT 2016

Does anyone has this issue also ?
Any input ?


On 28/10/16 15:36, Valentina Skorpion wrote:
>        Hello everyone,
>      I have been using yocto jethro in order to build my custom Linux 
> distribution for several devices ( qemuarm , sama5d4, etc) . I have 
> used the linux-yocto 4.1.5 kernel version and latest version packages. 
> After upgrading to yocto krogoth I have used a newer version of linux 
> kernel ( version 4.7.2 ) and newer version packages. I had some tcl 
> scripts which worked fine before but now  the following error has been 
> triggered:
>     error waiting for process to exit : child process lost is sigchld 
> ignored or trapped? )
>      This error is being triggered when tcl *exec *function is 
> executed. Even simpler commands such as "exec ls" triggers the same 
> error (the command is not executed).
>      I have tried to reproduce the error on yocto krogoth with older 
> versions of linux kernel. On linux-yocto 4.4 the same error appeared.  
> On linux-yocto 4.1.5 with some outdated packages (with older version, 
> only Tcl had the same version in all test cases) the exec function 
> runned fine (as I have mentioned before). To reproduce the error in 
> this case, SIGCHLD had to be trapped outside tclsh (with trap command 
> : trap "" CHLD), but even then, the command inside exec was executed 
> and only after that the mentioned error was triggered (similar to this 
> issue: 
> http://www.rkeene.org/projects/tcl/tcl.fossil/info/2982713fffffffff ).
>      It seemed at a package (on which depends Tcl) traps or ignores 
> the SIGCHLD.  After some research, a similar issue has been reported ( 
> https://sourceware.org/bugzilla/show_bug.cgi?id=19861 ). In a newer 
> glibc version, fork functionality could not use IFUNC resolver so it 
> would trigger in tcl the SIGCHLD error. A patch has been applied to 
> glib pt-fork.c ( 
> https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=blobdiff;f=nptl/pt-fork.c;h=db9b61d9aa172c7886b6ed3decb355a3aa4c9036;hp=b65d6b4eddc0c17a39825a9cd30d0dc3fb5b141f;hb=f06f3f05b48c72e2c9b0fa78671f94fd22d67da8;hpb=7838d298d895f65247fb6b498db03a4336fc0506 
> ) in order to fix the issue and now works fine.
>      Has somebody encountered this issue too? Has anyone used this 
> patch to fix the problem or used another fix? Thanks!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/yocto/attachments/20161102/68e98555/attachment.html>

More information about the yocto mailing list