[yocto] Recipe naming

Martin Jansa martin.jansa at gmail.com
Sat Aug 3 04:17:42 PDT 2013


On Sat, Aug 03, 2013 at 12:07:41PM +0100, Paul Barker wrote:
> On 3 August 2013 11:52, Paul Barker <paul at paulbarker.me.uk> wrote:
> > Should I call this:
> >
> >     "opkg_testing.bb"
> >     set PREFERRED_VERSION_opkg = "testing" to use
> >
> 
> Martin has just commented elsewhere that having this recipe in a meta-opkg layer
> will always override the recipe in oe-core:
> 
> > You probably know about this already, but for other possible users of this
> > layer:
> >
> > bitbake will always select "devel" version from meta-opkg layer if it has
> > higher BBFILE_PRIORITY even if you put negative DEFAULT_PREFERRENCE into
> > "devel" recipes. Only if you put lower-than-oe-core BBFILE_PRIORITY in
> > layer.conf then it will force user to select "devel" version by
> > PREFERRED_VERSION.
> 
> So maybe opkg-testing_{version} would work better.

opkg-testing with PROVIDES = "opkg" won't work well for runtime dependencies
(even if you add RPROVIDES unless something will explicitly pull
opkg-testing into the image - VIRTUAL-RUNTIME vars...)

I would name the recipe opkg_git.bb with PV corresponding to real
version based on SRCREV e.g. "1.9+git${SRCPV}".

with
BBFILE_PRIORITY = "4"
and
PREFERRED_VERSION_opkg = "1.9+git%"
it should work as expected

This should be discussed on oe-core ML rather then yocto ML.

-- 
Martin 'JaMa' Jansa     jabber: Martin.Jansa at gmail.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://lists.yoctoproject.org/pipermail/yocto/attachments/20130803/c53974d9/attachment.pgp>


More information about the yocto mailing list