<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=us-ascii">
</head>
<body dir="auto">
<div></div>
<div>Prabhu,</div>
<div><br>
</div>
<div>I use the 5.0.11.p7.</div>
<div>According with log: 5.0.11.33433.</div>
<div><br>
</div>
<div>Regards</div>
<div>Julio</div>
<div><br>
On Jan 21, 2016, at 10:54 AM, Prabhu Sundararaj <<a href="mailto:prabhu.sundararaj@nxp.com">prabhu.sundararaj@nxp.com</a>> wrote:<br>
<br>
</div>
<div>
<meta name="Generator" content="Microsoft Exchange Server">
<!-- converted from text --><style><!-- .EmailQuote { margin-left: 1pt; padding-left: 4pt; border-left: #800000 2px solid; } --></style>
<div>
<div>checked 4.6.9.p13, 5.0.11.p4/p7, and there is no place to use swait_prepare_locked or swait_finish_locked symbol.</div>
<div>Which gpu driver version did you use?<br>
<br>
<div class="x_acompli_signature">Best Regards,<br>
Prabhu</div>
<br>
</div>
<br>
<br>
<br>
<div class="x_gmail_quote">On Wed, Jan 20, 2016 at 6:49 PM -0800, "Julio Cruz Barroso"
<span dir="ltr"><<a href="mailto:julio.cruz@smartmatic.com" target="_blank">julio.cruz@smartmatic.com</a>></span> wrote:<br>
<br>
</div>
</div>
<font size="2"><span style="font-size:10pt;">
<div class="PlainText">Hi Prabhu,<br>
<br>
I'm using the kernel version 3.14.28.<br>
<br>
Regards<br>
<br>
Julio<br>
<br>
On Jan 20, 2016, at 11:16 PM, Prabhu Sundararaj <<a href="mailto:prabhu.sundararaj@nxp.com">prabhu.sundararaj@nxp.com</a>> wrote:<br>
<br>
Wondering what is the kernel version you are using? The problem does not seem to occur in linux-imx with 3.14 kernel.<br>
<br>
Best Regards,<br>
Prabhu<br>
<br>
-----Original Message-----<br>
From: Julio Cruz Barroso [<a href="mailto:julio.cruz@smartmatic.com">mailto:julio.cruz@smartmatic.com</a>]
<br>
Sent: Wednesday, January 20, 2016 5:59 AM<br>
To: Otavio Salvador <<a href="mailto:otavio.salvador@ossystems.com.br">otavio.salvador@ossystems.com.br</a>>; Prabhu Sundararaj <<a href="mailto:prabhu.sundararaj@nxp.com">prabhu.sundararaj@nxp.com</a>><br>
Cc: <a href="mailto:meta-freescale@yoctoproject.org">meta-freescale@yoctoproject.org</a>;
<a href="mailto:dominic.sacre@gmx.de">dominic.sacre@gmx.de</a><br>
Subject: RE: [meta-freescale] wandboard-rt & kernel-module-imx-gpu-viv error<br>
<br>
Hi Otavio, Prabhu,<br>
<br>
The previous patch help to build the imx-gpu-viv module for the Linux-wandboard-rt. After testing, there is the following issue:<br>
<br>
[    3.692132] galcore: Unknown symbol swait_prepare_locked (err -22)<br>
[    3.701981] galcore: Unknown symbol swait_finish_locked (err -22)<br>
<br>
These symbols are part of the linux-rt patch. To solve it, the EXPORT_SYMBOL directive was used at /kernel/sched/wait-simple.c. The board is able to show QT application using eglfs (no xorg). Attached the additional patch.<br>
<br>
Julio<br>
<br>
-----Original Message-----<br>
From: Otavio Salvador [<a href="mailto:otavio.salvador@ossystems.com.br">mailto:otavio.salvador@ossystems.com.br</a>]<br>
Sent: Tuesday, January 12, 2016 7:13 PM<br>
To: Julio Cruz Barroso <<a href="mailto:julio.cruz@smartmatic.com">julio.cruz@smartmatic.com</a>>; Prabhu Sundararaj <<a href="mailto:prabhu.sundararaj@nxp.com">prabhu.sundararaj@nxp.com</a>><br>
Cc: <a href="mailto:meta-freescale@yoctoproject.org">meta-freescale@yoctoproject.org</a>;
<a href="mailto:dominic.sacre@gmx.de">dominic.sacre@gmx.de</a><br>
Subject: Re: [meta-freescale] wandboard-rt & kernel-module-imx-gpu-viv error<br>
<br>
Hello Julio,<br>
<br>
> On Tue, Jan 12, 2016 at 4:47 AM, Julio Cruz Barroso <<a href="mailto:julio.cruz@smartmatic.com">julio.cruz@smartmatic.com</a>> wrote:<br>
> I'm trying to build a core-image-minimal for "wandboard-rt", but an error show-up compiling the module "kernel-module-imx-gpu-viv".<br>
> <br>
> I found two ways to solve this issue:<br>
> <br>
> 1. Apply a similar patch proposed by Dominic some months ago <br>
> ([meta-freescale] [meta-fsl-arm-extra][PATCH] linux-wandboard-rt: Add initial recipe), but this time, for the external module 2. Disable the kernel module and use the built-in. For this, it suggest to use the option defined by Otavio 5 month ago (patch-v2-0-5-dynamically-choose-between-built-in-or-external-vivante-gpu-kernel-driver#post8).
 MACHINE_USES_VIVANTE_KERNEL_DRIVER_MODULE = "0" in the local.conf file.<br>
> <br>
> Currently, both sources (module and built-in) have difference and I'm not sure if the applied patch will be enough. Dominic, do you have any comments?<br>
<br>
Ideally we ought to fix the kernel module source. Prabhu, is it possible for you to review the patch proposed by Julio? It seems good from my point of view and harmless for normal kernel as well.<br>
<br>
-- <br>
Otavio Salvador                             O.S. Systems<br>
<a href="http://www.ossystems.com.br">http://www.ossystems.com.br</a>        <a href="http://code.ossystems.com.br">
http://code.ossystems.com.br</a><br>
Mobile: +55 (53) 9981-7854            Mobile: +1 (347) 903-9750<br>
</div>
</span></font></div>
</body>
</html>