<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <div class="moz-cite-prefix">Thats because they have different
      names. They all start with "imx" (with the exception of the
      eglvivsink).<br>
      These are entirely different plugins, written from scratch.<br>
      <br>
      On 2013-12-09 22:14, Joshua Kurland wrote:<br>
    </div>
    <blockquote
cite="mid:CAPuotkcMo=BBhp=9gs_d7=KVBF=9iGjFEbL3ZCtDTC1g3YA4Vg@mail.gmail.com"
      type="cite">
      <div dir="ltr">Thanks Carlos, that script helped out a lot and I
        am able to compile the binaries.  I modified your script to use
        the wandboard-quad sysroots and ran the script.  I then ran
        ./waf and  sudo ./waf install.  I copied the binaries from
        /usr/local/lib to my board in /usr/lib and
        /usr/lib/gstreamer-1.0.  Everything seemed fine, but when I use
        gst-inspect-1.0 to find mfw_v4lsink nothing is found.  The same
        can be said for other Freescale elements that I had been using
        in Gstreamer-0.10.
        <div>
          <br>
        </div>
        <div>Thanks,</div>
        <div>Josh Kurland</div>
      </div>
      <div class="gmail_extra"><br>
        <br>
        <div class="gmail_quote">On Mon, Dec 9, 2013 at 3:31 PM, Carlos
          Rafael Giani <span dir="ltr"><<a moz-do-not-send="true"
              href="mailto:dv@pseudoterminal.org" target="_blank">dv@pseudoterminal.org</a>></span>
          wrote:<br>
          <blockquote class="gmail_quote" style="margin:0 0 0
            .8ex;border-left:1px #ccc solid;padding-left:1ex">
            <div class="im">On 2013-12-09 21:05, Joshua Kurland wrote:<br>
              <blockquote class="gmail_quote" style="margin:0 0 0
                .8ex;border-left:1px #ccc solid;padding-left:1ex">
                I am having a bit of difficulty compiling the
                gstreamer-imx binaries using waf.  I set up the
                environment variables and ran waf, but it was unable to
                find 'libfslvpuwrap'.  But  libfslvpuwrap.pc is found in
                my sysroot/cortexa9hf-vfp-neon-poky-linux-gnueabi/usr/lib/pkgconfig/libfslvpuwrap.pc.
                 I am adding libfslvpuwrap as a package under the
                IMAGE_INSTALL section of my image recipe, is this not
                the correct way?  I've attached my environment script as
                well as the error log, I would appreciate any help I can
                get.<br>
                <br>
                Thanks,<br>
                Josh Kurland<br>
                <br>
              </blockquote>
              <br>
            </div>
            The environment variables look wrong to me.<br>
            1. export CFLAGS="--sysroot=/opt/poky/1.5+gst/sysroots/x86_64-linux/usr/bin/cortexa9-vfp-neon-poky-linux-gnueabi"
            : sysroot is not supposed to point to the cross compiler
            directory, but to the sysroot of the *device* (same goes for
            the LDFLAGS, the PKG_CONFIG_SYSROOT_DIR, and the kernel
            headers path)<br>
            2. the "/build" part of the kernel headers path needs to be
            removed<br>
            3. do you use hardfloat or softfloat? In one place, you use
            cortexa9, in another, cortexa9hf<br>
            <br>
            I attached an example script that may be clearer (at
            successfully builds the plugins). It builds for the Sabre SD
            DualLite platform.<br>
            <br>
            cheers<br>
          </blockquote>
        </div>
        <br>
      </div>
    </blockquote>
    <br>
  </body>
</html>