<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<meta name="Generator" content="Microsoft Word 12 (filtered medium)">
<style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:Tahoma;
        panose-1:2 11 6 4 3 5 4 4 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:12.0pt;
        font-family:"Times New Roman","serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
p.MsoAcetate, li.MsoAcetate, div.MsoAcetate
        {mso-style-priority:99;
        mso-style-link:"Balloon Text Char";
        margin:0in;
        margin-bottom:.0001pt;
        font-size:8.0pt;
        font-family:"Tahoma","sans-serif";}
span.EmailStyle17
        {mso-style-type:personal-reply;
        font-family:"Calibri","sans-serif";
        color:#1F497D;}
span.BalloonTextChar
        {mso-style-name:"Balloon Text Char";
        mso-style-priority:99;
        mso-style-link:"Balloon Text";
        font-family:"Tahoma","sans-serif";}
.MsoChpDefault
        {mso-style-type:export-only;}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>
<body lang="EN-US" link="blue" vlink="purple">
<div class="WordSection1">
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D">Hi Friket,<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D"><o:p> </o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D">I was about to ask you about the galcore module, as I always use it as built-in I thought you were using this way too. I“m glad it worked.<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D"><o:p> </o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D">About the gesture recognition demo, what is going on ? what kind of errors are you getting ?<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D"><o:p> </o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D">Regards,<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D">andre<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D"><o:p> </o:p></span></p>
<div style="border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0in 0in 0in">
<p class="MsoNormal"><b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif"">From:</span></b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif""> Fikret Alim [mailto:fikret.alim@gmail.com]
<br>
<b>Sent:</b> Friday, November 29, 2013 10:19 AM<br>
<b>To:</b> Silva Andre-B22958<br>
<b>Cc:</b> Otavio Salvador; meta-freescale@yoctoproject.org<br>
<b>Subject:</b> Re: [meta-freescale] X11 is not working on IMX.6<o:p></o:p></span></p>
</div>
<p class="MsoNormal"><o:p> </o:p></p>
<div>
<p class="MsoNormal">Hi again,<o:p></o:p></p>
</div>
<div>
<p class="MsoNormal"> <o:p></o:p></p>
</div>
<div>
<p class="MsoNormal">Thank you for your answers. I have solved the problems by starting the GPU module<o:p></o:p></p>
</div>
<div>
<p class="MsoNormal"> <o:p></o:p></p>
</div>
<div>
<p class="MsoNormal">$ modprobe galcore<o:p></o:p></p>
</div>
<div>
<p class="MsoNormal"> <o:p></o:p></p>
</div>
<div>
<p class="MsoNormal">and with the display setting<o:p></o:p></p>
</div>
<div>
<p class="MsoNormal">$ export DISPLAY=:0.0<o:p></o:p></p>
</div>
<div>
<p class="MsoNormal"> <o:p></o:p></p>
</div>
<div>
<p class="MsoNormal">By this way I can run the X11 samples on Yocto, but I have still problems with Andre's gesture recognition example :)<o:p></o:p></p>
</div>
<div>
<p class="MsoNormal"> <o:p></o:p></p>
</div>
<div>
<p class="MsoNormal">I can not compile anything with softfp, because the compiler can not find stubs_soft.h. In Yocto, there is only stubs.h and stubs_hard.h<o:p></o:p></p>
</div>
<div>
<p class="MsoNormal"> <o:p></o:p></p>
</div>
<div>
<p class="MsoNormal">Best Regards,<o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="margin-bottom:12.0pt">Fikret<o:p></o:p></p>
</div>
<div>
<p class="MsoNormal">On Thu, Nov 28, 2013 at 5:47 PM, Andre Silva <<a href="mailto:Andre.Silva@freescale.com" target="_blank">Andre.Silva@freescale.com</a>> wrote:<o:p></o:p></p>
<p class="MsoNormal">Hi Guys,<br>
<br>
I will need to check that. One question: if you let it as softfp, does it work ?<br>
<br>
Regards,<br>
Andre<o:p></o:p></p>
<div>
<div>
<p class="MsoNormal" style="margin-bottom:12.0pt"><br>
-----Original Message-----<br>
From: <a href="mailto:otavio.salvador@gmail.com">otavio.salvador@gmail.com</a> [mailto:<a href="mailto:otavio.salvador@gmail.com">otavio.salvador@gmail.com</a>] On Behalf Of Otavio Salvador<br>
Sent: Thursday, November 28, 2013 12:02 PM<br>
To: Fikret Alim; Silva Andre-B22958<br>
Cc: <a href="mailto:meta-freescale@yoctoproject.org">meta-freescale@yoctoproject.org</a><br>
Subject: Re: [meta-freescale] X11 is not working on IMX.6<br>
<br>
Hello Fikret,<br>
<br>
On Wed, Nov 27, 2013 at 5:05 AM, Fikret Alim <<a href="mailto:fikret.alim@gmail.com">fikret.alim@gmail.com</a>> wrote:<br>
> I am trying to run X11 examples included in gpu_sdk_v1.00 package. I<br>
> am using Yocto fsl-gui-image. I have tried to run 06_Texturing example<br>
> under<br>
> GLES2.0 folder. I have only modified -mfloat-abi variable in the<br>
> Makefile from softfp to hard. Then I have compiled the code, but<br>
> unfortunately it is not running on IMX.6 board. I got the following<br>
> error message when I try to run ./06_Texturing;<br>
><br>
> 06_Texturing: ../common/src/fsl_egl.c:51 fsl_getNativeDisplay:<br>
> Assertion 'eglNativeDisplayType != ((void *)0)' failed<br>
><br>
> Aborted.<br>
><br>
> What can be wrong? It seems that there is a problem at XOpenDisplay<br>
> function which is called by fsl_getNativeDisplay function. Is there<br>
> anything to be done to enable X11? I checked that the libraries are<br>
> loaded under /usr/libē What should I do?<br>
<br>
Andre, do you have any clue?<br>
<br>
--<br>
Otavio Salvador                             O.S. Systems<br>
<a href="http://www.ossystems.com.br/" target="_blank">http://www.ossystems.com.br</a>        <a href="http://code.ossystems.com.br/" target="_blank">http://code.ossystems.com.br</a><br>
Mobile: <a href="tel:%2B55%20%2853%29%209981-7854">+55 (53) 9981-7854</a>            Mobile:
<a href="tel:%2B1%20%28347%29%20903-9750">+1 (347) 903-9750</a><br>
<br>
<o:p></o:p></p>
</div>
</div>
</div>
<p class="MsoNormal"><o:p> </o:p></p>
</div>
</body>
</html>