<html><head><meta http-equiv="Content-Type" content="text/html charset=windows-1252"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;">There’s quite a few issues which I’ve brought up with Freescale support but haven’t received any ETA or updates just that “Vivante’s working on it”.  If you have some time available I can put aside some time as well to get my examples updated and published on github so that we can work through them as this has been a major roadblock for us (we ended up using GLES 2.0 Shaders instead, though they’re also loaded with various Vivante issues).<div><br></div><div>One major issue is the lack of support for cl_khr_gl_sharing which would allow us to use the textures loaded with glTexDirectVIVMap_t within an OpenCL kernel.  Alternatively would be for OpenCL to be able to correctly use host memory, for example a buffer created by the IPU, without requiring a copy (since everything is in the same RAM and we can ensure specific pixel formats).</div><div><br></div><div>Another issue is just one of performance, simple image convolutions take much longer than expected to complete.  This seems to be an issue with the way the Vivante driver handles it’s memory and is also seen in GLES 2.0.  In one example I submitted to Freescale we were seeing 32ms to process a simple convolution on a 720p image, something we’d expect to take no more than 10% of that time given the GPU and bus speed of the system.  At the time we were told it was a known issue with glTexDirectVIVMap_t, though I’m not really sold on that as we can demonstrate the same issue using glTexImage2D.  In the case of GLES we can see that a glFlush takes (my numbers might be slightly off going from memory here) approximately 5ms but does not completely flush the image, a glFinish does completely flush the image but takes 20ms.</div><div><br></div><div><br><div><div>On Nov 29, 2013, at 10:32 AM, Andre Silva <<a href="mailto:Andre.Silva@freescale.com">Andre.Silva@freescale.com</a>> wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite">

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<meta name="Generator" content="Microsoft Word 12 (filtered medium)">
<style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:Tahoma;
        panose-1:2 11 6 4 3 5 4 4 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:12.0pt;
        font-family:"Times New Roman","serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
p
        {mso-style-priority:99;
        mso-margin-top-alt:auto;
        margin-right:0in;
        mso-margin-bottom-alt:auto;
        margin-left:0in;
        font-size:12.0pt;
        font-family:"Times New Roman","serif";}
p.MsoAcetate, li.MsoAcetate, div.MsoAcetate
        {mso-style-priority:99;
        mso-style-link:"Balloon Text Char";
        margin:0in;
        margin-bottom:.0001pt;
        font-size:8.0pt;
        font-family:"Tahoma","sans-serif";}
span.BalloonTextChar
        {mso-style-name:"Balloon Text Char";
        mso-style-priority:99;
        mso-style-link:"Balloon Text";
        font-family:"Tahoma","sans-serif";}
span.EmailStyle20
        {mso-style-type:personal;
        font-family:"Calibri","sans-serif";
        color:#1F497D;}
span.EmailStyle21
        {mso-style-type:personal-reply;
        font-family:"Calibri","sans-serif";
        color:#1F497D;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-size:10.0pt;}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->

<div lang="EN-US" link="blue" vlink="purple">
<div class="WordSection1"><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D">Hi Sebastien,
<o:p></o:p></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D"> </span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D">Thanks for adding this information, I didn´t work with the OpenCV OCL module yet, as I only see CUDA in the OpenCV cmake config, I thought it only used CUDA.<o:p></o:p></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D"> </span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D">What is the issues you mentioned in the Vivante OCL driver ? We do have some limitations like size of the kernel (limited number of instructions), but I am
 not aware of these various issues you mentioned.<o:p></o:p></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D"> </span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D">Regards,<o:p></o:p></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D">Andre<o:p></o:p></span></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D"> </span></p>
<div>
<div style="border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0in 0in 0in"><p class="MsoNormal"><b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif"">From:</span></b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif""> Sébastien Taylor [<a href="mailto:sebastientaylor@gmail.com">mailto:sebastientaylor@gmail.com</a>]
<b>On Behalf Of </b>Sébastien Taylor<br>
<b>Sent:</b> Friday, November 29, 2013 3:29 PM<br>
<b>To:</b> Silva Andre-B22958<br>
<b>Cc:</b> Fikret Alim; <a href="mailto:meta-freescale@yoctoproject.org">meta-freescale@yoctoproject.org</a>; Otavio Salvador<br>
<b>Subject:</b> Re: [meta-freescale] X11 is not working on IMX.6<o:p></o:p></span></p>
</div>
</div><p class="MsoNormal"><o:p> </o:p></p><p class="MsoNormal">Just to clarify, the OpenCV OCL module is OpenCL not CUDA though they also have a GPU module which is CUDA.  The issue with the OpenCL module on the i.MX6 is that it requires Full Profile.  Many of the algorithms could conceivably be ported
 to Embedded Profile, but the various issues with the Vivante OpenCL driver would first need to be fixed.<o:p></o:p></p>
<div><p class="MsoNormal"><o:p> </o:p></p>
<div>
<div><p class="MsoNormal">On Nov 29, 2013, at 10:01 AM, Andre Silva <<a href="mailto:Andre.Silva@freescale.com">Andre.Silva@freescale.com</a>> wrote:<o:p></o:p></p>
</div><p class="MsoNormal"><br>
<br>
<o:p></o:p></p>
<div><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D">Hi Friket,</span><o:p></o:p></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D"> </span><o:p></o:p></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D">You are right, the OCL module in OpenCV is CUDA based, it doesn´t work for us. Using OpenCL in this case, you can base on OpenCL embedded profile tutorials
 you can find in the web also, I created a simple OCL SDK, that provides you a quick start for opencl application, unfortunately it is not available outside Freescale yet, there are some samples there (IP filtering) that you could use, I just need to check
 if I can share right now.</span><o:p></o:p></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D"> </span><o:p></o:p></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D">Regards,</span><o:p></o:p></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D">Andre
</span><o:p></o:p></p><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D"> </span><o:p></o:p></p>
<div style="border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0in 0in 0in"><p class="MsoNormal"><b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif"">From:</span></b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif""> Fikret Alim [<a href="mailto:fikret.alim@gmail.com">mailto:fikret.alim@gmail.com</a>]
<br>
<b>Sent:</b> Friday, November 29, 2013 1:14 PM<br>
<b>To:</b> Silva Andre-B22958<br>
<b>Cc:</b> Otavio Salvador; <a href="mailto:meta-freescale@yoctoproject.org">meta-freescale@yoctoproject.org</a><br>
<b>Subject:</b> Re: [meta-freescale] X11 is not working on IMX.6</span><o:p></o:p></p>
</div><p class="MsoNormal"> <o:p></o:p></p>
<div><p class="MsoNormal">Dear Andre,<o:p></o:p></p>
<div><p class="MsoNormal"> <o:p></o:p></p>
</div>
<div><p class="MsoNormal">When I run gesture demo, I get the following console output now;<o:p></o:p></p>
</div>
<div><p class="MsoNormal"> <o:p></o:p></p>
</div>
<div>
<div><p class="MsoNormal">root@imx6qsabrelite:~/gpu_samp/bin# ./gesture<o:p></o:p></p>
</div>
<div><p class="MsoNormal"> <o:p></o:p></p>
</div>
<div><p class="MsoNormal">Using: min: 15, max: 40, val: -1<o:p></o:p></p>
</div>
<div><p class="MsoNormal"> <o:p></o:p></p>
</div>
<div><p class="MsoNormal">Yellow: ./gesture 15 40 -1<o:p></o:p></p>
</div>
<div><p class="MsoNormal">Skin: ./gesture 5 30 20<o:p></o:p></p>
</div>
<div><p class="MsoNormal"> <o:p></o:p></p>
</div>
<div><p class="MsoNormal">Loading netweights...OK<o:p></o:p></p>
</div>
<div><p class="MsoNormal"> <o:p></o:p></p>
</div>
<div><p class="MsoNormal">Insufficient buffer memory on /dev/video0 -- decreaseing buffers<o:p></o:p></p>
</div>
<div><p class="MsoNormal">Insufficient buffer memory on /dev/video0 -- decreaseing buffers<o:p></o:p></p>
</div>
<div><p class="MsoNormal">Insufficient buffer memory on /dev/video0 -- decreaseing buffers<o:p></o:p></p>
</div>
<div><p class="MsoNormal">Insufficient buffer memory on /dev/video0 -- decreaseing buffers<o:p></o:p></p>
</div>
<div><p class="MsoNormal">Initializing OpenCV...OK<o:p></o:p></p>
</div>
<div><p class="MsoNormal">Initializing OGLES2...OK<o:p></o:p></p>
</div>
<div><p class="MsoNormal">Creating the Stage...OK<o:p></o:p></p>
</div>
<div><p class="MsoNormal">Creating the Theater...OK<o:p></o:p></p>
</div>
<div><p class="MsoNormal">Creating the Status Panel...OKError: Resource not found.<o:p></o:p></p>
</div>
<div><p class="MsoNormal">Error: Resource not found.<o:p></o:p></p>
</div>
<div><p class="MsoNormal"> <o:p></o:p></p>
</div>
<div><p class="MsoNormal">Control Disabled<o:p></o:p></p>
</div>
<div><p class="MsoNormal"> <o:p></o:p></p>
</div>
<div><p class="MsoNormal">Now, the application is running, but I can only see black screen on the monitor. There is an error message as seen above, but I didn't have time to check from the software. Do you have an idea about the error message?<o:p></o:p></p>
</div>
<div><p class="MsoNormal"> <o:p></o:p></p>
</div>
<div><p class="MsoNormal">I have one more question: Actually I am not interested in OpenGL, because we want to perform image processing. So, OpenCL will be more suitable for us, but I couldn't find any examples other than hello world for IMX.6. I searched if we
 can use OpenCV OCL module on IMX.6, but I learned that it is not possible. So, if you know a way to use GPU for image processing, please recommend a way to me (such as an example using both OpenCV and OpenCL)<o:p></o:p></p>
</div>
<div><p class="MsoNormal"> <o:p></o:p></p>
</div>
<div><p class="MsoNormal">Thanks&Best Regards,<o:p></o:p></p>
</div>
<div><p class="MsoNormal">Fikret<o:p></o:p></p>
</div>
</div>
</div>
<div><p class="MsoNormal" style="margin-bottom:12.0pt"> <o:p></o:p></p>
<div><p class="MsoNormal">On Fri, Nov 29, 2013 at 2:49 PM, Andre Silva <<a href="mailto:Andre.Silva@freescale.com" target="_blank">Andre.Silva@freescale.com</a>> wrote:<o:p></o:p></p>
<div>
<div><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D">Hi Friket,</span><o:p></o:p></p><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D"> </span><o:p></o:p></p><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D">I was about to ask you about the galcore module, as I always use it as built-in I thought you were
 using this way too. I´m glad it worked.</span><o:p></o:p></p><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D"> </span><o:p></o:p></p><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D">About the gesture recognition demo, what is going on ? what kind of errors are you getting ?</span><o:p></o:p></p><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D"> </span><o:p></o:p></p><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D">Regards,</span><o:p></o:p></p><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D">andre</span><o:p></o:p></p><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D"> </span><o:p></o:p></p>
<div style="border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0in 0in 0in"><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"><b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif"">From:</span></b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif""> Fikret Alim [mailto:<a href="mailto:fikret.alim@gmail.com" target="_blank">fikret.alim@gmail.com</a>]
<br>
<b>Sent:</b> Friday, November 29, 2013 10:19 AM<br>
<b>To:</b> Silva Andre-B22958<br>
<b>Cc:</b> Otavio Salvador; <a href="mailto:meta-freescale@yoctoproject.org" target="_blank">
meta-freescale@yoctoproject.org</a></span><o:p></o:p></p>
<div>
<div><p class="MsoNormal"><br>
<b>Subject:</b> Re: [meta-freescale] X11 is not working on IMX.6<o:p></o:p></p>
</div>
</div>
</div>
<div>
<div><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
<div><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">Hi again,<o:p></o:p></p>
</div>
<div><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
</div>
<div><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">Thank you for your answers. I have solved the problems by starting the GPU module<o:p></o:p></p>
</div>
<div><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
</div>
<div><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">$ modprobe galcore<o:p></o:p></p>
</div>
<div><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
</div>
<div><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">and with the display setting<o:p></o:p></p>
</div>
<div><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">$ export DISPLAY=:0.0<o:p></o:p></p>
</div>
<div><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
</div>
<div><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">By this way I can run the X11 samples on Yocto, but I have still problems with Andre's gesture recognition example :)<o:p></o:p></p>
</div>
<div><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
</div>
<div><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">I can not compile anything with softfp, because the compiler can not find stubs_soft.h. In Yocto, there is only stubs.h and stubs_hard.h<o:p></o:p></p>
</div>
<div><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
</div>
<div><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">Best Regards,<o:p></o:p></p>
</div>
<div><p class="MsoNormal" style="mso-margin-top-alt:auto;margin-bottom:12.0pt">Fikret<o:p></o:p></p>
</div>
<div><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">On Thu, Nov 28, 2013 at 5:47 PM, Andre Silva <<a href="mailto:Andre.Silva@freescale.com" target="_blank">Andre.Silva@freescale.com</a>> wrote:<o:p></o:p></p><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto">Hi Guys,<br>
<br>
I will need to check that. One question: if you let it as softfp, does it work ?<br>
<br>
Regards,<br>
Andre<o:p></o:p></p>
<div>
<div><p class="MsoNormal" style="mso-margin-top-alt:auto;margin-bottom:12.0pt"><br>
-----Original Message-----<br>
From: <a href="mailto:otavio.salvador@gmail.com" target="_blank">otavio.salvador@gmail.com</a> [mailto:<a href="mailto:otavio.salvador@gmail.com" target="_blank">otavio.salvador@gmail.com</a>] On Behalf Of Otavio Salvador<br>
Sent: Thursday, November 28, 2013 12:02 PM<br>
To: Fikret Alim; Silva Andre-B22958<br>
Cc: <a href="mailto:meta-freescale@yoctoproject.org" target="_blank">meta-freescale@yoctoproject.org</a><br>
Subject: Re: [meta-freescale] X11 is not working on IMX.6<br>
<br>
Hello Fikret,<br>
<br>
On Wed, Nov 27, 2013 at 5:05 AM, Fikret Alim <<a href="mailto:fikret.alim@gmail.com" target="_blank">fikret.alim@gmail.com</a>> wrote:<br>
> I am trying to run X11 examples included in gpu_sdk_v1.00 package. I<br>
> am using Yocto fsl-gui-image. I have tried to run 06_Texturing example<br>
> under<br>
> GLES2.0 folder. I have only modified -mfloat-abi variable in the<br>
> Makefile from softfp to hard. Then I have compiled the code, but<br>
> unfortunately it is not running on IMX.6 board. I got the following<br>
> error message when I try to run ./06_Texturing;<br>
><br>
> 06_Texturing: ../common/src/fsl_egl.c:51 fsl_getNativeDisplay:<br>
> Assertion 'eglNativeDisplayType != ((void *)0)' failed<br>
><br>
> Aborted.<br>
><br>
> What can be wrong? It seems that there is a problem at XOpenDisplay<br>
> function which is called by fsl_getNativeDisplay function. Is there<br>
> anything to be done to enable X11? I checked that the libraries are<br>
> loaded under /usr/libç What should I do?<br>
<br>
Andre, do you have any clue?<br>
<br>
--<br>
Otavio Salvador                             O.S. Systems<br>
<a href="http://www.ossystems.com.br/" target="_blank">http://www.ossystems.com.br</a>        <a href="http://code.ossystems.com.br/" target="_blank">http://code.ossystems.com.br</a><br>
Mobile: <a href="tel:%2B55%20%2853%29%209981-7854" target="_blank">+55 (53) 9981-7854</a>            Mobile:
<a href="tel:%2B1%20%28347%29%20903-9750" target="_blank">+1 (347) 903-9750</a><o:p></o:p></p>
</div>
</div>
</div><p class="MsoNormal" style="mso-margin-top-alt:auto;mso-margin-bottom-alt:auto"> <o:p></o:p></p>
</div>
</div>
</div>
</div>
</div><p class="MsoNormal"> <o:p></o:p></p>
</div>
</div><p class="MsoNormal">_______________________________________________<br>
meta-freescale mailing list<br>
<a href="mailto:meta-freescale@yoctoproject.org">meta-freescale@yoctoproject.org</a><br>
<a href="https://lists.yoctoproject.org/listinfo/meta-freescale">https://lists.yoctoproject.org/listinfo/meta-freescale</a><o:p></o:p></p>
</div><p class="MsoNormal"><o:p> </o:p></p>
</div>
</div>
</div>

</blockquote></div><br></div></body></html>