<html><head><meta http-equiv="Content-Type" content="text/html charset=windows-1252"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;">It is not supported no, as you mentioned it would require full profile and even then generally requires a pretty beefy GPU as well.  Is the header installed into the sysroot or just part of the sources?  You should be able to compile the OpenCL support as Iím not aware of host side differences between FP/EP but at run-time the kernels will fail to run and possibly fail to compile as well.<div><br><div><div>On Nov 28, 2013, at 6:56 AM, Fikret Alim <<a href="mailto:fikret.alim@gmail.com">fikret.alim@gmail.com</a>> wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite"><p>Hello,</p><p>Does IMX6Q support OCL module of OpenCV for GPU programming? I have found ocl header insider opencv2/nonfree/ocl.hpp, but the ocl.hpp here includes opencv2/ocl/ocl.hpp which does not exist. There is no OCL folder inside opencv2 folder.</p><p>Is it supported? If yes, do I need to download from anywhere?</p><p>In the link below, it is mentioned that OpenCL version should be larger than 1.1 with FULL PROFILE in order to use OCL module. As far as I know, IMX6Q supports OpenCL 1.1 with Embedded Profile. It should not be supported according to the documentation, but I am confused for seeing ocl.hpp under nonfree folder.</p><p><a class="jive-link-external-small" href="http://docs.opencv.org/modules/ocl/doc/introduction.html">OpenCL Module Introduction ó OpenCV 2.4.7.0 documentation</a></p><p>Thanks&Best Regards,</p><p>Fikret</p>
_______________________________________________<br>meta-freescale mailing list<br><a href="mailto:meta-freescale@yoctoproject.org">meta-freescale@yoctoproject.org</a><br>https://lists.yoctoproject.org/listinfo/meta-freescale<br></blockquote></div><br></div></body></html>