<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=us-ascii">
<meta name="Generator" content="Microsoft Word 12 (filtered medium)">
<style><!--
/* Font Definitions */
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:Tahoma;
        panose-1:2 11 6 4 3 5 4 4 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:#0563C1;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:#954F72;
        text-decoration:underline;}
p
        {mso-style-priority:99;
        mso-margin-top-alt:auto;
        margin-right:0in;
        mso-margin-bottom-alt:auto;
        margin-left:0in;
        font-size:12.0pt;
        font-family:"Times New Roman","serif";}
span.EmailStyle18
        {mso-style-type:personal;
        font-family:"Calibri","sans-serif";
        color:windowtext;}
span.EmailStyle19
        {mso-style-type:personal-reply;
        font-family:"Calibri","sans-serif";
        color:#1F497D;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-size:10.0pt;}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>
<body lang="EN-US" link="#0563C1" vlink="#954F72">
<div class="WordSection1">
<p class="MsoNormal"><span style="color:#1F497D">Doug,<o:p></o:p></span></p>
<p class="MsoNormal"><span style="color:#1F497D"><o:p> </o:p></span></p>
<p class="MsoNormal"><span style="color:#1F497D">I think you might be seeing issues with the new toolchain 4.8.   There were some ARM errata workarounds in defconfig in 3.10 to fix issues with new gcc toolchain.  Also the new eglibc has performance issues we
 are patching in our beta release.<o:p></o:p></span></p>
<p class="MsoNormal"><span style="color:#1F497D"><br>
Try building on 4.7 toolchain which was I believe the same one that 3.5.7 was tested against.<o:p></o:p></span></p>
<p class="MsoNormal"><span style="color:#1F497D"><o:p> </o:p></span></p>
<p class="MsoNormal"><span style="color:#1F497D">Best to switch to 3.10 as that will go GA not 3.5.7 which was stopped to move to an LTS kernel.  I think 3.10.9 is almost ready to be fully upstreamed into dora branch.   So until it is merged, use the master
 branch.  <o:p></o:p></span></p>
<p class="MsoNormal"><span style="color:#1F497D"><o:p> </o:p></span></p>
<p class="MsoNormal"><span style="color:#1F497D">Lauren<o:p></o:p></span></p>
<p class="MsoNormal"><span style="color:#1F497D"><o:p> </o:p></span></p>
<div>
<div style="border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0in 0in 0in">
<p class="MsoNormal"><b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif"">From:</span></b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif""> meta-freescale-bounces@yoctoproject.org [mailto:meta-freescale-bounces@yoctoproject.org]
<b>On Behalf Of </b>Doug Schwanke<br>
<b>Sent:</b> Tuesday, November 05, 2013 12:19 PM<br>
<b>To:</b> meta-freescale@yoctoproject.org<br>
<b>Subject:</b> [meta-freescale] Kernel 3.5.7 hangs<o:p></o:p></span></p>
</div>
</div>
<p class="MsoNormal"><o:p> </o:p></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">I am trying to build kernel 3.5.7  Yocto ‘Dora’ using imx6qsabresd.  Everything builds without an error and I get a new uImage, as shown below.  However,  the kernel hangs while starting up. 
 Some folks in the imx community have tried using  CONFIG_EARLY_PRINTK=y, but there are no messages printed by kernel.<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif""># I first clean before changing versions in order to clean up the 3.0.35 files...<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">bitbake -c cleansstate linux-imx<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif""># change from 3.0.35 to 3.5.7 by adding the following line to my local.config<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">PREFERRED_VERSION_linux-imx_mx6 = "3.5.7"<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif""># rebuild kernel<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">bitbake linux-imx<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif""># rebuild image<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">bitbake core-image-minimal<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">=========================================<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">Output files...<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">tmp/deploy/images/imx6qsabresd/u-boot.imx -> u-boot-imx6qsabresd-v2013.10-r0.imx*<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">tmp/deploy/images/imx6qsabresd/u-boot-imx6qsabresd.imx -> u-boot-imx6qsabresd-v2013.10-r0.imx*<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">tmp/deploy/images/imx6qsabresd/u-boot-imx6qsabresd-v2013.10-r0.imx*<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">tmp/deploy/images/imx6qsabresd/uImage -> uImage--3.5.7-r0-imx6qsabresd-20131104212852.bin<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">tmp/deploy/images/imx6qsabresd/uImage--3.5.7-r0-imx6qsabresd-20131104212852.bin<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">tmp/deploy/images/imx6qsabresd/uImage--3.5.7-r0-imx6q-sabresd-20131104212852.dtb<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">tmp/deploy/images/imx6qsabresd/uImage-imx6qsabresd.bin -> uImage--3.5.7-r0-imx6qsabresd-20131104212852.bin<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">tmp/deploy/images/imx6qsabresd/uImage-imx6q-sabresd.dtb -> uImage--3.5.7-r0-imx6q-sabresd-20131104212852.dtb<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">=========================================<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">U-Boot 2013.10 (Nov 04 2013 - 09:49:56)<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">CPU:   Freescale i.MX6Q rev1.2 at 792 MHz<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">Reset cause: POR<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">Board: MX6-SabreSD<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">DRAM:  1 GiB<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">MMC:   FSL_SDHC: 0, FSL_SDHC: 1, FSL_SDHC: 2<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">*** Warning - bad CRC, using default environment<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">No panel detected: default to HDMI<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">Display: HDMI (1024x768)<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">In:    serial<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">Out:   serial<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">Err:   serial<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">Net:   FEC [PRIME]<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">Hit any key to stop autoboot:  0<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">mmc1 is current device<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">reading boot.scr<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">** Unable to read file boot.scr **<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">reading uImage<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">4686224 bytes read in 218 ms (20.5 MiB/s)<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">Booting from mmc ...<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">reading imx6q-sabresd.dtb<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">46128 bytes read in 20 ms (2.2 MiB/s)<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">## Booting kernel from Legacy Image at 12000000 ...<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">   Image Name:   Linux-3.5.7-1.0.0+g3285970<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">   Image Type:   ARM Linux Kernel Image (uncompressed)<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">   Data Size:    4686160 Bytes = 4.5 MiB<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">   Load Address: 10008000<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">   Entry Point:  10008000<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">   Verifying Checksum ... OK<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">## Flattened Device Tree blob at 18000000<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">   Booting using the fdt blob at 0x18000000<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">   Loading Kernel Image ... OK<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">   Using Device Tree in place at 18000000, end 1800e42f<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">Starting kernel ...<o:p></o:p></span></p>
<p><span style="font-size:11.0pt;font-family:"Calibri","sans-serif"">(hangs here…)<o:p></o:p></span></p>
</div>
</body>
</html>