<html>
  <head>
    <meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <div class="moz-cite-prefix">On 05/28/2013 09:04 AM, Eric Bénard
      wrote:<br>
    </div>
    <blockquote cite="mid:20130528090442.0b4ad7a4@e6520eb" type="cite">
      <pre wrap="">Le Tue, 28 May 2013 08:23:14 +0200,
Bastiaan de Nooij <a class="moz-txt-link-rfc2396E" href="mailto:nooijb.hotraco@gmail.com"><nooijb.hotraco@gmail.com></a> a écrit :

</pre>
      <blockquote type="cite">
        <pre wrap="">On 05/22/2013 05:02 PM, Eric Bénard wrote:
</pre>
        <blockquote type="cite">
          <pre wrap="">Hi Bastiaan,

Le Wed, 22 May 2013 16:46:42 +0200,
Bastiaan de Nooij <a class="moz-txt-link-rfc2396E" href="mailto:nooijb.hotraco@gmail.com"><nooijb.hotraco@gmail.com></a> a écrit :
</pre>
          <blockquote type="cite">
            <pre wrap="">Qt-embedded builds fine.
However running actual opengl ES2 code results in a segmentation fault.
Also qtdemo results in a segmentation fault.

I would like to give you more detailed information, however I'm a little
short on time to work on this.
I will try to make a stacktrace tomorrow.

</pre>
          </blockquote>
          <pre wrap="">FWIW : I have a working (runtime tested with hellogl_es2 -platform
eglfs) bbappend for meta-qt5 and eglfs platform on i.MX6. I'll try to
send it by friday.

Eric
</pre>
        </blockquote>
        <pre wrap="">
Hi Eric, Otavio,

at this point I'm convinced I need QT 5 for the project I'm working on,
it delivers far better performance for QML (according to various 
internet sources).

I'm still very much interested in testing your QT5 patches/bbappends,
to see if I can achieve decent performance on the IMX6S.

</pre>
      </blockquote>
      <pre wrap="">patches sent this night, please check the ML

Eric
</pre>
    </blockquote>
    Hi Eric, Otavio,<br>
    I'm afraid I need a little more help.... <br>
    I'm quite new to yocto and as a result I find it difficult to get
    results.<br>
    <br>
    what I've done so far:<br>
    <br>
    I set-up the <span class="bold"><span itemscope=""
        itemtype="http://data-vocabulary.org/Breadcrumb"><a
          href="https://github.com/Freescale/fsl-community-bsp-base"
          class="js-slide-to" data-branch="master" data-direction="back"
          itemscope="url"><span itemprop="title">fsl-community-bsp-base</span></a>
        repo for my wandboard-solo.</span></span><br>
    I added the meta-qt5 layer from the github repository (and adjusted
    my bblayers.conf).<br>
    I applied the patch of Vol 77 of the ML on meta-fsl-arm.<br>
    I modified a core-image-minimal recepe to build qtbase qtbase-tools
    and qtbase-plugins.<br>
    <br>
    when I build this image, the build proceeds fine, however the
    resulting image contains version 5.0.1 of QT for opengl Desktop (!?)<br>
    (according to the do_configure logfile for qtbase)<br>
    <br>
    In volume 78 of the ML, Eric mentions "cherry-pick e7a477a" <br>
    I 'm afraid don't know how. I tried 'git cherry-pick e7a477a' on the
    meta-qt5 repo, but this results in:<br>
    <font face="monospace">fatal: ambiguous argument 'e7a477a': unknown
      revision or path not in the working tree.</font><br>
    <br>
    According to the same mail I also should apply the patches from <br>
    <font face="monospace"><a class="moz-txt-link-freetext"
href="http://lists.openembedded.org/pipermail/openembedded-devel/2013-May/090861.html">http://lists.openembedded.org/pipermail/openembedded-devel/2013-May/090861.html</a></font>
    ?<br>
    Then, after setting QT version 5.0.2 in
    conf/distro/include/qt5-versions.inc<br>
    I should be able to build a eglfs supporting version of qt5?<br>
    <br>
    If I get the last part right, the only thing I need help with is the
    cherry-picking part...<br>
    <br>
    Regards,<br>
    Bastiaan.<br>
    <br>
    <br>
    <br>
    <span class="bold"><span itemscope=""
        itemtype="http://data-vocabulary.org/Breadcrumb"></span></span><span
      class="bold"><span itemscope=""
        itemtype="http://data-vocabulary.org/Breadcrumb"><br>
        <br>
      </span></span><br>
    <br>
  </body>
</html>