[meta-freescale] u-boot can't read mtd flash partition writen by linux

Jonathan Poulin jopoulin at gmail.com
Fri Apr 7 06:30:49 PDT 2017


I answer to me for archive and help others.

My problem is effectively related to ECC strength used. I try the
configuration and the patch proposed by the following thread and it solve
my problem.



2017-03-31 16:45 GMT-04:00 Jonathan Poulin <jopoulin at gmail.com>:

> Hello,
> I built an image for a imx6-dual custom board using yocto krogoth with
> meta-fsl-arm. I used u-boot-fslc_2016.07 and linux-fslc-imx_4.1-1.0.x.
> I successfully burnt u-boot and the kernel to nand with mfgtool. But when
> I tried to boot it; u-boot got an error in accessing the kernel partition.
> ----
> NAND read: device 0 offset 0x500000, size 0x1e00000
> NAND read from offset 500000 failed -74
>  0 bytes read: ERROR
> -----
> If I write the kernel from u-boot then I can boot the kernel correctly.
> I also tried to erase and write the kernel from the kernel with
> flash_ereae and nand_write. Then I couldn't reboot and got the same error.
> I suspect an incompatibility in the ECC encoding protocol used by kernel
> and u-boot.
> The NAND chip used is MT29F8G08ABABAWP.
> Do anyone have a solution or a clue about this ?
> thanks
> Jonathan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/meta-freescale/attachments/20170407/833dfd6a/attachment.html>

More information about the meta-freescale mailing list