[meta-freescale] Confused with adding drivers to kernel via bitbake -c menuconfig

Alvin D.M. DIZON adm.dizon at pciltd.com.sg
Thu Feb 5 18:59:48 PST 2015

Hello Otavio,

If I set the drivers to be added as built-in, does that mean that the driver would be installed and loaded in the kernel? I ran "lsmod" and didn't see the bluetooth driver loaded. Am I missing something here?
From: otavio.salvador at gmail.com [otavio.salvador at gmail.com] on behalf of Otavio Salvador [otavio at ossystems.com.br]
Sent: Thursday, February 05, 2015 7:23 PM
To: Alvin D.M. DIZON
Cc: meta-freescale at yoctoproject.org
Subject: Re: [meta-freescale] Confused with adding drivers to kernel via bitbake -c menuconfig

On Thu, Feb 5, 2015 at 3:42 AM, Alvin D.M. DIZON
<adm.dizon at pciltd.com.sg> wrote:
> I would like to the generic USB bluetooth driver "btusb" to my i.MX6Q SABRE SD, so that my USB Bluetooth dongle(Cambridge Silicon Radio). Upon reading https://community.freescale.com/docs/DOC-100847 I enabled the Bluetooth subsystem support, RFCOMM, BNEP, and HIDP, as well as the HCI USB driver. I saved the .config file and copied it to the directory where my Linux recipe is (linux-imx_3.10.17.bb). I then renamed my .config file into defconfig, made a new folder called "files" and placed the defconfig in it. I also made a .bbappend file that contained
> FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
> SRC_URI += "file://defconfig"
> I then ran "bitbake -c cleansstate linux-imx", after that I ran "bitbake fsl-image-x11". I flashed the resulting .sdcard file to an SD card, booted up my board, but found no trace of btusb. I tried doing "bitbake -f -c compile linux-imx" and then "bitbake -f -c deploy linux-imx", and copied the resulting uImage to my SD card's /media/Boot folder, but still no trace of btusb. I checked the tar archive for the kernel modules found in the /tmp/deploy/images/imx6qsabresd folder, and found two files called modules.order and modules.builtin, the btusb driver is listed in the modules.builtin file, but not mentioned in the modules.order file, I have also tried compiling the driver as module, and then ran the same commands as listed in the said link, but could not find the module. What am I doing wrong here? Any help will be will be appreciated, since I am new to Linux and the Yocto Project.

You might have made it built-in, no? in this case no module will be
generated but it will be included in the kernel.

Otavio Salvador                             O.S. Systems
http://www.ossystems.com.br        http://code.ossystems.com.br
Mobile: +55 (53) 9981-7854            Mobile: +1 (347) 903-9750

  Innovative Manufacturing Solutions. Professionally Delivered!

The information contained in this email is confidential and is intended for addressee(s) only. If you have received this email in error, please notify the originator immediately. Nothing in this email shall constitute an offer or acceptance leading to a legally binding contract which shall only arise from a formal written agreement between yourselves and ourselves in the form of a Purchase Order issued by us and accepted by you in writing. For the avoidance of doubt, this email shall not be construed in any way as a formal written agreement. We accept no liability for any damage arising from alteration of the contents of this message by a third party or as a result of any virus being passed on. Please consider your environmental responsibility before printing this e-mail.

More information about the meta-freescale mailing list