[meta-freescale] X11 is not working on IMX.6

Andre Silva Andre.Silva at freescale.com
Fri Nov 29 04:49:41 PST 2013

Hi Friket,

I was about to ask you about the galcore module, as I always use it as built-in I thought you were using this way too. I´m glad it worked.

About the gesture recognition demo, what is going on ? what kind of errors are you getting ?


From: Fikret Alim [mailto:fikret.alim at gmail.com]
Sent: Friday, November 29, 2013 10:19 AM
To: Silva Andre-B22958
Cc: Otavio Salvador; meta-freescale at yoctoproject.org
Subject: Re: [meta-freescale] X11 is not working on IMX.6

Hi again,

Thank you for your answers. I have solved the problems by starting the GPU module

$ modprobe galcore

and with the display setting
$ export DISPLAY=:0.0

By this way I can run the X11 samples on Yocto, but I have still problems with Andre's gesture recognition example :)

I can not compile anything with softfp, because the compiler can not find stubs_soft.h. In Yocto, there is only stubs.h and stubs_hard.h

Best Regards,
On Thu, Nov 28, 2013 at 5:47 PM, Andre Silva <Andre.Silva at freescale.com<mailto:Andre.Silva at freescale.com>> wrote:
Hi Guys,

I will need to check that. One question: if you let it as softfp, does it work ?


-----Original Message-----
From: otavio.salvador at gmail.com<mailto:otavio.salvador at gmail.com> [mailto:otavio.salvador at gmail.com<mailto:otavio.salvador at gmail.com>] On Behalf Of Otavio Salvador
Sent: Thursday, November 28, 2013 12:02 PM
To: Fikret Alim; Silva Andre-B22958
Cc: meta-freescale at yoctoproject.org<mailto:meta-freescale at yoctoproject.org>
Subject: Re: [meta-freescale] X11 is not working on IMX.6

Hello Fikret,

On Wed, Nov 27, 2013 at 5:05 AM, Fikret Alim <fikret.alim at gmail.com<mailto:fikret.alim at gmail.com>> wrote:
> I am trying to run X11 examples included in gpu_sdk_v1.00 package. I
> am using Yocto fsl-gui-image. I have tried to run 06_Texturing example
> under
> GLES2.0 folder. I have only modified -mfloat-abi variable in the
> Makefile from softfp to hard. Then I have compiled the code, but
> unfortunately it is not running on IMX.6 board. I got the following
> error message when I try to run ./06_Texturing;
> 06_Texturing: ../common/src/fsl_egl.c:51 fsl_getNativeDisplay:
> Assertion 'eglNativeDisplayType != ((void *)0)' failed
> Aborted.
> What can be wrong? It seems that there is a problem at XOpenDisplay
> function which is called by fsl_getNativeDisplay function. Is there
> anything to be done to enable X11? I checked that the libraries are
> loaded under /usr/libç What should I do?

Andre, do you have any clue?

Otavio Salvador                             O.S. Systems
http://www.ossystems.com.br<http://www.ossystems.com.br/>        http://code.ossystems.com.br<http://code.ossystems.com.br/>
Mobile: +55 (53) 9981-7854<tel:%2B55%20%2853%29%209981-7854>            Mobile: +1 (347) 903-9750<tel:%2B1%20%28347%29%20903-9750>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/meta-freescale/attachments/20131129/7079fa69/attachment-0001.html>

More information about the meta-freescale mailing list