[meta-freescale] Kernel 3.5.7 hangs

Doug Schwanke doug.schwanke at firstviewconsultants.com
Thu Nov 7 12:56:55 PST 2013

I tried 3.10 on the master branch.  I get the following messages during my

# change from 3.0.35 to 3.10 by adding the following line to my local.config

PREFERRED_VERSION_linux-imx_mx6 = "3.10"


build$ bitbake core-image-minimal

Loading cache: 100% |###########################################| ETA:

Loaded 1751 entries from dependency cache.

NOTE: Resolving any missing task queue dependencies

NOTE: preferred version 3.10 of linux-imx not available (for item

NOTE: versions of linux-imx available: 3.0.35 3.5.7

NOTE: preferred version 3.10 of linux-imx not available (for item

NOTE: versions of linux-imx available: 3.0.35 3.5.7

NOTE: preferred version 3.10 of linux-imx not available (for item

NOTE: versions of linux-imx available: 3.0.35 3.5.7


Build Configuration:

BB_VERSION        = "1.21.0"

BUILD_SYS         = "x86_64-linux"

NATIVELSBSTRING   = "Ubuntu-12.04"

TARGET_SYS        = "arm-poky-linux-gnueabi"

MACHINE           = "imx6qsabresd"

DISTRO            = "poky"

DISTRO_VERSION    = "1.5+snapshot-20131107"

TUNE_FEATURES     = "armv7a vfp neon callconvention-hard cortexa9"

TARGET_FPU        = "vfp-neon"


meta-yocto        = "(nobranch):d6cc7c8ed76c8b1117cf03c7bd4b0742f98f79b3"

meta-oe           = "(nobranch):ffb5434823195cbdc41c76a110eaa6ae04e2b010"

meta-fsl-arm      = "(nobranch):9135a32b50800cac2c3feb0bac1f19c3d6743add"

meta-fsl-arm-extra = "(nobranch):0512f5fd03033b8ab707fcc8624fac68b79a321d"

meta-fsl-demos    = "(nobranch):3aa554d5aacaab946013527e45ddbc3af8a25bba"


Am I doing something wrong or just trying to use 3.10 before it's been
integrated into master?


From: Lauren Post [mailto:RAA013 at freescale.com] 
Sent: Tuesday, November 05, 2013 2:43 PM
To: Doug Schwanke; meta-freescale at yoctoproject.org
Subject: RE: [meta-freescale] Kernel 3.5.7 hangs




I think you might be seeing issues with the new toolchain 4.8.   There were
some ARM errata workarounds in defconfig in 3.10 to fix issues with new gcc
toolchain.  Also the new eglibc has performance issues we are patching in
our beta release.

Try building on 4.7 toolchain which was I believe the same one that 3.5.7
was tested against.


Best to switch to 3.10 as that will go GA not 3.5.7 which was stopped to
move to an LTS kernel.  I think 3.10.9 is almost ready to be fully
upstreamed into dora branch.   So until it is merged, use the master branch.




From: meta-freescale-bounces at yoctoproject.org
<mailto:meta-freescale-bounces at yoctoproject.org>
[mailto:meta-freescale-bounces at yoctoproject.org] On Behalf Of Doug Schwanke
Sent: Tuesday, November 05, 2013 12:19 PM
To: meta-freescale at yoctoproject.org <mailto:meta-freescale at yoctoproject.org>

Subject: [meta-freescale] Kernel 3.5.7 hangs


I am trying to build kernel 3.5.7  Yocto 'Dora' using imx6qsabresd.
Everything builds without an error and I get a new uImage, as shown below.
However,  the kernel hangs while starting up.  Some folks in the imx
community have tried using  CONFIG_EARLY_PRINTK=y, but there are no messages
printed by kernel.

# I first clean before changing versions in order to clean up the 3.0.35

bitbake -c cleansstate linux-imx

# change from 3.0.35 to 3.5.7 by adding the following line to my

PREFERRED_VERSION_linux-imx_mx6 = "3.5.7"

# rebuild kernel

bitbake linux-imx

# rebuild image

bitbake core-image-minimal


Output files...

tmp/deploy/images/imx6qsabresd/u-boot.imx ->

tmp/deploy/images/imx6qsabresd/u-boot-imx6qsabresd.imx ->


tmp/deploy/images/imx6qsabresd/uImage ->



tmp/deploy/images/imx6qsabresd/uImage-imx6qsabresd.bin ->

tmp/deploy/images/imx6qsabresd/uImage-imx6q-sabresd.dtb ->


U-Boot 2013.10 (Nov 04 2013 - 09:49:56)

CPU:   Freescale i.MX6Q rev1.2 at 792 MHz

Reset cause: POR

Board: MX6-SabreSD

DRAM:  1 GiB


*** Warning - bad CRC, using default environment

No panel detected: default to HDMI

Display: HDMI (1024x768)

In:    serial

Out:   serial

Err:   serial

Net:   FEC [PRIME]

Hit any key to stop autoboot:  0

mmc1 is current device

reading boot.scr

** Unable to read file boot.scr **

reading uImage

4686224 bytes read in 218 ms (20.5 MiB/s)

Booting from mmc ...

reading imx6q-sabresd.dtb

46128 bytes read in 20 ms (2.2 MiB/s)

## Booting kernel from Legacy Image at 12000000 ...

   Image Name:   Linux-3.5.7-1.0.0+g3285970

   Image Type:   ARM Linux Kernel Image (uncompressed)

   Data Size:    4686160 Bytes = 4.5 MiB

   Load Address: 10008000

   Entry Point:  10008000

   Verifying Checksum ... OK

## Flattened Device Tree blob at 18000000

   Booting using the fdt blob at 0x18000000

   Loading Kernel Image ... OK

   Using Device Tree in place at 18000000, end 1800e42f

Starting kernel ...

(hangs here.)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/meta-freescale/attachments/20131107/32385a11/attachment.html>

More information about the meta-freescale mailing list