[meta-freescale] Trouble installing fsl codec libraries

Daniel Kenji Morgan daniel.kenji.morgan at gmail.com
Fri May 31 02:52:01 PDT 2013

(2013/05/31 4:54), Sandoval Gonzalez Leonardo-B42214 wrote:
> have you tried building a 'fsl-image-gui' image? that image contains freescale's gstreamer plugins.
> Leo
> ________________________________________
> From: meta-freescale-bounces at yoctoproject.org [meta-freescale-bounces at yoctoproject.org] on behalf of Daniel Kenji Morgan [daniel.kenji.morgan at gmail.com]
> Sent: Thursday, May 30, 2013 6:36 AM
> To: meta-freescale at yoctoproject.org
> Subject: [meta-freescale] Trouble installing fsl codec libraries
> Hello,
> I'm trying to play audio files using gstreamer on the SABRE Lite board.
> I've tried building an image by inheriting "core-image" and adding "gstreamer" and "gst-fsl-plugin" to CORE_IMAGE_EXTRA_INSTALL.
> For some reason, none of the codecs included in "libfslcodec" are installed onto my image even though they are built.
> The parsers in libfslparser are installed without any problems.
> I've tried messing about with various recipes, but have had no success so far in getting the codecs to be installed.
> Can anyone give me some insight into what I might be doing wrong?
> I am currently using Poky 1.3 (danny) for all required meta layers.
> _______________________________________________
> meta-freescale mailing list
> meta-freescale at yoctoproject.org
> https://lists.yoctoproject.org/listinfo/meta-freescale

Thank you for the reply.
Here is an update.

It turns out the codecs are installed, but the codec *wrapper* libraries 
are NOT.
I tried building both "fsl-image-gui" and "fsl-image-test", but the 
results are the same.

I did a comparison against an image built using LTIB, and it turns out 
that "/usr/lib/imx-mm/audio-codec/wrap" contains the wrapper libraries.
The yocto images does not contain this directory nor any of the wrapper 

Forgive me if my assumption is wrong, but don't the following lines in 
"do_install_append" from libfslcodec_3.0.1.bb delete the wrapper libraries?

# LTIB move the files around or gst-fsl-plugin won't find them
for p in $(find ${D}${libdir}/imx-mm -mindepth 1 -maxdepth 1 -type d); do
     mv $p/* ${D}${libdir}
     rmdir $p
rmdir ${D}${libdir}/imx-mm

The packaging in "populate_packages_prepend" also seems to place the 
wrapper libraries into "/usr/lib/wrap" which does not match the path 
found in the LTIB generated image.

More information about the meta-freescale mailing list