[meta-freescale] Problem with root fs when booting from memory.

Otavio Salvador otavio at ossystems.com.br
Tue May 21 11:48:24 PDT 2013

On Tue, May 21, 2013 at 3:47 PM, Otavio Salvador <otavio at ossystems.com.br>wrote:

> On Tue, May 21, 2013 at 2:51 AM, Juha Vuorivirta <jvp.vuorivirta at gmail.com
> > wrote:
>> Hi!
>> I have used tftpboot to load uImage from tftp server and after that tried
>> to run image from memory using bootm command, like guide
>> uboot_mx6x.pdf says.
>> Kernel loads fine but root fs could not be found.
>> System is halted here:
>> List of all partitions:
>> 1f00            1024 mtdblock0  (driver?)
>> 1f01            3072 mtdblock1  (driver?)
>> b300         7757824 mmcblk0  driver: mmcblk
>> b310            2048 mmcblk0boot1  (driver?)
>> b308            2048 mmcblk0boot0  (driver?)
>> b318         7761920 mmcblk1  driver: mmcblk
>>   b319            8192 mmcblk1p1 00000000-0000-0000-0000-000000000000
>>   b31a          864256 mmcblk1p2 00000000-0000-0000-0000-000000000000
>> No filesystem could mount root, tried:  jffs2
>> Kernel panic - not syncing: VFS: Unable to mount root fs on
>> unknown-block(0,0)
> You seem to have another system in emmc. It has a pending patch going to
> dylan but I don't think it has been merged already.

For reference:

commit 6a7aa9cac2fc128ffc9ea4416426335e06db345a
Author: Otavio Salvador <otavio at ossystems.com.br>
Date:   Mon Apr 22 08:52:29 2013 -0300

    udev-extraconf: Avoid mounting unknown filesystems

    Depending on kernel version used, the system can hung when trying to
    mount the extended partition (not the logical one) as it is a holder
    for other partitions and does not have a filesystem in it.

    To avoid this to happen we just mount partitions when these are using
    known filesystems so it does not try to mount a partition for an
    unsupported filesystem.

    Reported-by: Vladan Jovanovic <vladan.jovanovic at gmail.com>
    Reported-by: Leonardo Sandoval Gonzalez <b42214 at freescale.com>
    (From OE-Core rev: 895c9685a7f95dc84786213f945895a504a16254)

    Signed-off-by: Otavio Salvador <otavio at ossystems.com.br>
    Tested-by: Vladan Jovanovic <vladan.jovanovic at gmail.com>
    Signed-off-by: Saul Wold <sgw at linux.intel.com>
    Signed-off-by: Richard Purdie <richard.purdie at linuxfoundation.org>

Otavio Salvador                             O.S. Systems
http://www.ossystems.com.br        http://projetos.ossystems.com.br
Mobile: +55 (53) 9981-7854            Mobile: +1 (347) 903-9750
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/meta-freescale/attachments/20130521/dba81ca3/attachment.html>

More information about the meta-freescale mailing list