[meta-freescale] [meta-fsl-demos][PATCH] vivante-gpu-sdk: Contribute recipe for Vivante GPU Samples

Otavio Salvador otavio at ossystems.com.br
Tue May 21 09:13:52 PDT 2013


On Tue, May 21, 2013 at 12:27 PM, Diego <diego.ml at zoho.com> wrote:

> In data martedì 21 maggio 2013 11:34:54, Otavio Salvador ha scritto:
> ...
>
> > +++ b/recipes-graphics/vivante-gpu-sdk/vivante-gpu-sdk_1.00.bb
> > > @@ -0,0 +1,35 @@
> > > +SUMMARY = "Vivante GPU SDK Samples"
> > > +DESCRIPTION = "Freescale's adaptation of Jeff Molofee demos"
> >
> > Is this description accurate?
> >
>
> These are the first lines of every source file:
> /*
>  * This code was created by Jeff Molofee '99
>  * (ported to Linux by Ti Leggett '01)
>  * (ported to i.mx51, i.mx31 and x11 by Freescale '10)
>  * If you've found this code useful, please let him know.
>  *
>  * Visit Jeff at http://nehe.gamedev.net/
>  *
>  */
>
> I know the description is not the best one can produce, but this is not an
> established project, nor a one man/enterprise work. At least the X11 part
> is
> not Vivante's nor Freescale's specific at all.


What about:

"Set of sample applications compatible with Vivante GPU"

?

...
>
> > +SRC_URI[md5sum] = "344c9a260b46a00f86eb5cb73bf729e0"
> > > +SRC_URI[sha256sum] =
> > > "0f0a576ce1a08719ee1018832ae808ee723fad27a534c9739b5feec6d7435c57"
> > > +
> > > +S = "${WORKDIR}/${PN}-${PV}"
> > > +GLES11DIR = "${S}/Samples/GLES1.1"
> >
> > You can avoid this setting:
> >
> > WORKDIR = "${S}/Samples/GLES1.1"
> >
>
> I'll have multiple "workdirs", as this initial version is just for GLES1.1,
> but Samples folder has three subfolders:
> GLES1.1
> GLES2.0
> OpenVG
> each one has its own Makefile, and no common Makefile. I'm not interested
> in
> creating a common Makefile with a patch, as they might even get packaged
> separately in the future according to chipset support.
> According to that, would you still use just:
> WORKDIR = "${S}/Samples/GLES1.1"
>

I agree here; you can try to get the patch already supporting them. I'd use
a 'for' loop to handle it, if possible.


> > > +VIVANTE_INSTALL_DIR = "/opt/${PN}"
> >
> > > +VIVANTE_INSTALL_DEST_DIR = "${D}${VIVANTE_INSTALL_DIR}"
> >
> >
> > I'd use these explicitly as the variable name is bigger than the content
> of
> > it ;-)
> >
>
> Shorter code is not necessarily better or clearer code. However if you want
> I'll follow your suggestion.
>

The problem with this is someone looking in the recipe needs to go there
and check what is the value of it. I think it is an indirection which does
not make it easier to read. We shouldn't keep changing this values so an
indirection here does not add much I think.

...
>
> > +       install -d "${VIVANTE_INSTALL_DEST_DIR}"
>
> > +       oe_runmake -f Makefile.x11 install
> > > +       cp -r bin/ "${VIVANTE_INSTALL_DEST_DIR}"
> >
> > Uh? make install does not handle this?
> >
>
> This is not in any way an "established project which installs in standard
> paths". It's more a "bunch of samples patched in the years, started quite
> some
> time ago, and intended just to be compiled and started locally by the
> learning
> developer".


Arrg! I see.


> > > +}
> > > +
> > > +FILES_${PN} += "${VIVANTE_INSTALL_DIR}"
> > > +FILES_${PN}-dbg = "${VIVANTE_INSTALL_DIR}/*/*/.debug"
>
> Thanks for your review. If you can clear out the WORKDIR vs multiple
> Makefiles
> in subdirs issue I'll post the updated patch.
>

Thanks by working on this; this will be of great value for users :-)

Regards,

-- 
Otavio Salvador                             O.S. Systems
http://www.ossystems.com.br        http://projetos.ossystems.com.br
Mobile: +55 (53) 9981-7854            Mobile: +1 (347) 903-9750
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/meta-freescale/attachments/20130521/e40f3470/attachment.html>


More information about the meta-freescale mailing list