[meta-freescale] resolution not changing

PAPARO Nino (MM) nino.paparo at magnetimarelli.com
Mon May 20 07:32:46 PDT 2013

Hi Eric,
Thank you very much for your help!
Running this command
setenv bootargs $bootargs video=mxcfb0:dev=lcd,CLAA-WVGA,bpp=24,if=RGB666
enabled 24 bit on my linux image (I checked with fbset ), but I think I'm still missing something because If for example I run Midori, all the pages and images seems to use few colors.
I modified  xorg.conf to change my screens timings and modeline but It did't fix the issue.
Is MACHINE imx6qsabrelite deprecated and  nitrogen6x should be used instead?



-----Original Message-----
From: Eric Nelson [mailto:eric.nelson at boundarydevices.com] 
Sent: Thursday, May 16, 2013 9:40 AM
To: PAPARO Nino (MM)
Cc: Eric Bénard; Alexander Keller; meta-freescale at yoctoproject.org
Subject: Re: [meta-freescale] resolution not changing

Hi Nino,

On 05/16/2013 05:58 AM, PAPARO Nino (MM) wrote:
> Hi,
> I'm having a similar issue with a 800x480 rgb screen, I'd like to change the colordepth to 24.
> The uboot setting I'm using is:
> setenv bootargs $bootargs video=mxcfb0:dev=lcd,CLAA-WVGA,if=RGB666
> and I tried setting it to:
> setenv bootargs $bootargs video=mxcfb0:dev=lcd,800x480,if=RGB24

I think you want 800x480M at 60 here instead of 800x480.

> but this does'nt seem to work.
> Any help would be appreciated.
> Nino

The "if=RGBx" parameter controls the output pixel format to match the display. It doesn't change the frame-buffer memory layout.

For that, you want to use the 'bpp=N' flag.

setenv bootargs $bootargs video=mxcfb0:dev=lcd,CLAA-WVGA,bpp=24,if=RGB666

You can verify this after boot by looking in /sys:
	# cat /sys/class/graphics/fb0/bits_per_pixel



More information about the meta-freescale mailing list