[meta-freescale] hob error when adding opencv package...or really any package

Otavio Salvador otavio at ossystems.com.br
Wed May 8 08:24:22 PDT 2013

On Tue, May 7, 2013 at 4:03 PM, Richard Cagley <rcagley at toyon.com> wrote:
> Following these instructions
> http://www.ossystems.com.br/blog/2013/04/15/yocto-with-boundary-devices-
> nitrogen6x-5-steps-only/
> (basically bitbake fsl-image-test)
> And then running hob in the build directory I'm unable to add/modify any
> package selection. I get the errors below...any ideas?
> ---
> Hob Exception - Error running command '['matchFile', 'hob-image.bb']':
> Traceback (most recent call last):
>   File "/opt/fsl-community-bsp/sources/poky/bitbake/lib/bb/command.py",
> line 68, in runCommand
>     result = command_method(self, commandline)
>   File "/opt/fsl-community-bsp/sources/poky/bitbake/lib/bb/command.py",
> line 210, in matchFile
>     return command.cooker.matchFile(fMatch)
>   File "/opt/fsl-community-bsp/sources/poky/bitbake/lib/bb/cooker.py",
> line 1142, in matchFile
>     raise NoSpecificMatch
> NoSpecificMatch

I didn't test Hob lately but it does have  some issues with our BSP.

The most serious one that I am aware of is the lack of mechanism to
add custom filesystems on it. So we cannot add the '.sdcard' for

I tried it and it worked fine to add/remove packages so this specific
error might be something at your side. Did you change something in
local.conf or bblayers.conf?


Otavio Salvador                             O.S. Systems
E-mail: otavio at ossystems.com.br  http://www.ossystems.com.br
Mobile: +55 53 9981-7854              http://projetos.ossystems.com.br

More information about the meta-freescale mailing list