[meta-freescale] Qt5 with Yocto

Philip Craig phil at blackmoth.com.au
Sun Dec 15 13:49:56 PST 2013

On Mon, Dec 16, 2013 at 5:16 AM, Morgan McKenzie <rmtm at uvic.ca> wrote:
> Hi,
> So I've tried updating my repo and when I went to build again the meta-qt5
> build is running into problems. I've tried on both master and dora branches
> (when I switched to master I switched the repo and meta-qt5) but I'm getting
> an error related to QUrl. I even tried creating a new repo and starting from
> scratch.
> I think it's related to this - I'm not sure how to go about fixing it in the
> meta-qt5 build though: http://qt-project.org/forums/viewthread/25896
> It seems to be failing at the following - not sure why it's even compiling
> that as I've specified DISTRO_FEATURES_remove += "x11 wayland"
> .../build/tmp/work/cortexa9hf-vfp-neon-mx6-poky-linux-gnueabi/qtbase/5.1.1-r0/build/src/plugins/platforms/xcb

Put the DISTRO_FEATURES setting in your local.conf or distro conf, not
the image bb.

More information about the meta-freescale mailing list