[meta-freescale] Qt5 with Yocto

Morgan McKenzie speedin_up at hotmail.com
Tue Dec 10 15:34:56 PST 2013


I'm fairly new to Yocto and trying to build Qt5 from git, and am having a few issues. I used to use LTIB for image generation so I may have a few bad habits that might need correcting - I'll do my best to explain what I'm doing and any advice would be welcomed. (For the record I used to have no problem getting qt5 compiled using LTIB - I understand the build process of it fairly wel, so this is more a matter of not being able to do what I want with Yocto).

I have a recipe that is made with (I'm fairly sure) all the packages/libraries I think I need, which generates an image.  What I used to do with LTIB and am trying to do now with Yocto is use the poky toolset and the sysroot to compile qt5 seperately and then have it included in the target image (I understand recipes and such enough to use for basic things but I'm not nearly at the level where I'd feel confident to write an entire one for compiling Qt5.)
>From what I've read I thought there would be a full system root I could use for development at     <build-root>/tmp/sysroots/imx6qsabreautoBut, it appears to be quite incomplete after a full build. Next I thought there would be a full root under <build-root>/tmp/deploy/images/imx6qsabreauto/<something>/   since the tar, ext3, and sdcard had to be created from something. But I haven't found anything - it must being deleted.
I eventually resorted to doing a 'bitbake -c populate_sdk uvic-image-ecocar'  (uvic-image-ecocar is my recipe). When I run this it appears to make a full sysroot. I think I could then copy all of this to a system root and have a working system - but this means that every time I update the build I'm going to have to then generate a new SDK and install it, which seems really backwards.
Am I missing something - there must be an easier way. For the record I have seen meta-qt5 but the lack of documentation on how to actually install and use it (along with the relative inactivity of the repo) make me wary of spending the time to get it working - unless someone suggests that they had success with it and are willing to explain how to start off.
What I would ideally like to be able to do is simply point my Qt compilation at a system root - something like <build-root>/tmp/deploy/images/imx6qsabreauto/uvic-image-ecocar-imx6qsabreauto/ and build, then next time I run bitbake as images are created they would be built from this and therefore the files I built would be included.
Is this at all possible, or is there a different approach I should take?

Morgan McKenzie

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.yoctoproject.org/pipermail/meta-freescale/attachments/20131210/764e0811/attachment-0001.html>

More information about the meta-freescale mailing list